Lineage-16.0 (Android Pie) Beta

Try it out

10th May:

And report back.

Note : if you have official lineage installed and want to upgrade, you need to change signing keys. See below.

Many thanks for z3ntu to participate and contribute a lot in this effort.


What seems to work:

  • Wifi
  • LTE
  • Phone
  • Bluetooth
  • FM Radio
  • Encryption
  • Youtube
  • Netflix
  • Camera
  • Flashlight
  • Tethering incl. Wifi, BT, USB
  • GPS
  • Selinux enabled
  • auto-brightness
  • off-mode charger

What does not work:

  • camera button doesn’t work until camera has at least been started once through app

  • encryption upgrade from 14.1 (see next post - tbc if right upgrade procedure was used)

  • Tell us (z3ntu/me)

Older downloads:


I can confirm 16.0 encrypts, and TWRP 3.2.3-0 as expected can’t handle the encryption, so business as usual there.

Installing 16.0 with a data partition encrypted with LineageOS 14.1 to make it work with TWRP (complete Advanced Wipe in TWRP otherwise) doesn’t result in a bootable OS (which worked with 15.1), with boot attempts resulting in:

"Decryption unsuccessful

The password you entered is correct, but unfortunately your data is corrupt.

To resume using your phone, you need to perform a factory reset. When you set up your phone after the reset, you’ll have an opportunity to restore any data that was backed up to your Google Account.


… where RESET PHONE is a button, but does nothing.

  • The TWRP factory reset (Wipe - Swipe to Factory Reset) doesn’t help.

  • Wiping everything apart from system doesn’t help either.

  • Really reformatting system and cache to ext4 instead of only wiping before installing 16.0 doesn’t help either.

  • Installing via TWRP’s Install or via TWRP’s ADB sideload makes no difference.

  • With or without installing makes no difference (I had included it in the install first and then checked again without it).

Seems 16.0 doesn’t like the old encryption … yet?
I know it’s supposed to be TWRP’s fault for not playing along with the new encryption, but 15.1 runs fine with the old encryption.


Great! Can it be installed “over” 15.1, or should it be a clean install?


Thank you @chrmhoffmann and @z3ntu. I really think that your contribution to the Fairphone cause cannot be overestimated.:slightly_smiling_face:

And while they probably won’t read this, the same goes for Fairphone’s own developers whose certainly frustrating struggle with the horrible challenges of G00gle certification comes with much less glossy spotlight, but deserves no less recognition. Maybe a Purple Heart would be appropriate for you folks. :wink:


First of all, thank you a lot @chrmhoffmann and @z3ntu!!! Looking forward to testing it.
I have the same question as @lklaus and the following: Any first estimates on the mobile network standby battery drain issue? How does 16.0 perform?


The Purple Heart is […] awarded […] to those wounded or killed while serving

:flushed: (bold by me) I hope that nobody is bitten to death by bugs (pun intended)!


Fantastic news!
I read this after Fairphone’s statement saying they were discontinuing Fairphone 2.
Thanks to @chrmhoffmann and @z3ntu my Fairphone 2 (and my partner’s…) will hopefully still be in my pocket well after the planned 5 years (I’ve had mine since January 2016…).
Let me express how grateful I am for all this work you put in over the past two years.


You need to change keys. See here

If you don’t want to do this you need to install from scratch.


Does encrypted upgrade from 15.1 work?


I used TWRP to install the ZIP and OpenGApps on top of an existing LineageOS 15.1, without starting from scratch or doing anything else.

So far, the system works fine (except for Pixel Launcher, which keeps crashing).
Anything I’m missing concerning the keys? :thinking:

Huge thanks for all your great work @chrmhoffmann and @z3ntu !

I thought you have to change keys when switching from official nightly to homegrown builds ?


Hmm - I probably just ignored the security warnings, at first :innocent:

After activating flight mode over night and deactivating it again in the morning, my phone didn’t connect to the mobile network anymore. (WiFi worked fine, but the network provider didn’t.)
Also, at reboot the SIM PIN was not requested anymore. I thus ended up without any mobile connection.

I’m back on 15.1 now, for the time being (also because I didn’t want to start from scratch with factory settings…)

You cannot migrate from official nightly to user keys without the procedure I linked up there.

You loose system app settings if you do what you did, so I guess that explains that you have some random stuff.


1 Like

Btw: @AnotherElk, did you do the user key change procedure when upgrading?

Great work! :heart_eyes:

I flashed the image in TWRP over (unencrypted) LOS 15.1. No resetting of dalvik/cache.

Apps and settings all still there :grin::+1: only the homescreen was reset (maybe also other things). Wifi credentials are still there.

I also had to reflash Magisk, F-Droid-priv. ext. and Nlp.

So far no issues with signing keys. I can imagine that this becomes an issue once we switch to the official release…

Camera Button does NOT work to start the App, but does WORK to take pictures in the app. Double pressing unlock button to start camera app works.

Location Services seems like G__%le removed the Battery Saving option :slightly_frowning_face:

Wifi seems to take slightly longer to detect 5Ghz networks.

DNS-over-TLS is implemented in Pie :smiley::+1:

Huge thanks again for keeping up with the pace of Android upgrades :clap::clap::clap:

1 Like

I didn’t upgrade.
After encrypting with 14.1, I wiped data and formatted system and cache and installed 16.0 from scratch.

Next I will try to rm - rf data before installing, as wiping only deletes all the files, but leaves the (then empty) directory structure in place … at least for me, don’t know whether that’s intended.

Then I’ll try your idea and install 15.1 on the 14.1 encryption, then upgrade to 16.0.

I’m having this “sort of flight mode” also with LOS15.1, very annoying, at least it get’s away with manual rebooting the phone.

Thanks. Don’t forget the signing keys bit when going to 16.


1 Like

I noticed that the adaptive brightness does not seem to work. Do I have to change some settings? Is anybody else experiencing this?