English

Lineage 15.1: Netguard blocks all traffic?

lineageos
network
Tags: #<Tag:0x00007fefc0ecc478> #<Tag:0x00007fefc0ecc338>

#1

Hi there,

just tried LineageOS 15.1 on my FP2 again. Installation (“dirty flash”) worked flawlessly, besides the fact that many, many tiny little features are gone :cry:

But I do have a big issue with the Netguard (Pro) firewall, as it blocks all traffic. I read/followed this FAQ entry tried turning it off/on again, even reinstalling it.
(Reinstalling is tricky though, as Android 8 Oreo seems to present a changed the device ID and presents individual device IDs to the installed apps requesting it. I think Netguard uses the device ID to compute the required key to unlock the pro features.)

I know this is not the Netguard support, but the only way to get Netguard support is one single endless thread on XDA where the problem has already been described but remained unsolved.

That XDA thread would be my last resort… Maybe one of you folks here has an idea?

Thanks!


Lineage-16.0 (Android Pie) Nightly
Lineage-16.0 (Android Pie) Beta
#2

Same here :frowning_face:. NetGuard blocks everything in LineageOS 15.1. But I haven’t found out more then you. It seems to be a problem with LineageOS 15.1 - nothing that affects only Fairphone.


#3

What exactly are you missing :slightly_smiling_face:?


#4

Have you tried contacting the developer at https://contact.faircode.eu/ ?


#5

Sorry, never got around to answer your replies. @Zebrafax, interesting that you encounter the same problem.
Yes, I did contact Marcel, the author of NetGuard, both for a new license for NetGuard on Android 8 Oreo and for this problem. Only received an answer on the license part though :frowning: Tried contacting him again today, asking for more information on the LOS issue (is there a ticket?) and offering help with debug logs etc.

Here’s his reply already:

Several people reported an issue about this, but I have no links at hand. You can always try to contact the LineageOS maintainer for your device.

In any case there is little I can do. I keep all my apps maintained, which is already enough work, so I am not actively pursuing things like this.

Too bad, but understandable.

Maybe @chrmhoffmann can help? I filed a ticket in the FP LOS bugtracker.

regards