English

Latest FP3+ manual update flasher program not working on windows 10(A.0132)

Hi Everyone,

I have a rooted FP3+ so when there are firmware updates i have to manually update my phone. I have not had previous issues with other manual updates - however the latest flashall.exe flashes for a split second on the screen with the following error message before closing again(had to record my screen and take a frame capture to obtain this image).

I have tested the flashall.exe file from the previous firmware update files(A.0129) i still had and that version of that executable works perfectly fine showing the typical options to delete or keep user data.

I download all my firmware from the fairphone official site and all my drivers are up to date - does anyone have any ideas as to what is going on with this latest firmware update package exe file?

Thanks everyone!

2 Likes

Welcome to the community forum.

Starts fine for me.

It even starts fine for me when started out of the ZIP archive directly (just for testing, I wouldn’t expect the whole process to succeed this way).
Did you already try to redownload the file?

Else … I can see several tmp[number].bat and tmp[number].exe files in C:\Users\[username]\AppData\Local\Temp\xtmp (the folder is hidden, just enter the complete path into the Explorer address bar to see it), apparently every run of FP3_flashall.exe creates 1 BAT file and 1 EXE file, and they seem to stay there after FP3_flashall.exe gets terminated.
Perhaps you can have a look at the situation there, I think e.g. file size of 0 bytes or something?

Did you already try to run FP3_flashall.exe as Administrator?

5 Likes

Hi there - sorry for the slightly late response and thanks for trying to assist me.

I do run all the stuff relating to flashing files on my phone as administrator by default as I am always a bit paranoid about permissions being denied during the flashing process.

I could try re downloading the firmware archive to see if it got somehow corrupted during download(current SHA256 archive digest: 3CE143B248A99439869D9ACA374C79C001B810DA98FE84D717FC91868CDC3574)

If re-downloading does not work then I may check the situation in the Temp folder to see what might be going on. I might have already tried to redownload it last night actually but i cant remember for sure as it was pretty late and was tired but i will try again.

I will update you on the situation :slight_smile:

OK, so i have redownloaded the firmware and the archive SHA digest matches that of the one i posted before so i know that the files are not corrupt. Same result as before unfortunately.

I did open that xtmp folder and when running the A.0129 flashall.exe i do see a batch file and a .exe file appear(even without running as administrator), however the A.0132 flashall.exe does not make these files even when run as administrator. Something seems to be blocking the exe from creating these files it seems, I cant piece it together as i have completely exited my antivirus and even changed the firmware directory but to no avail. I will think of what to possibly do next, this is a very weird problem.

You could try checking the properties of the zip or even the flasher’s batch files to see if they’re blocked for some reason

Otherwise, if you’re rooted with Magisk you might be able to do the update from the device itself (I was able to). Do make sure fastboot is installed and working on your PC just in case the boot slot needs to be switched after updating. I posted the steps I took in the update thread

1 Like

Unfortunately the system OTA update fails even when i temporarily restore the stock boot image via the magisk app - I probably modified the /system folder somehow and its making the system data verity check fail - this is why I flash these updates manually as i have had this issue before.

I have tried ‘unblocking’ the archive and re-extracting the firmware files but this flashall.exe problem persists. I also have working fastboot on my windows 10 install - I will check your guide to see if it needs updating, thanks :slight_smile:

I do have a ubuntu dual boot setup which i could try to use to flash the firmware much more directly than through this windows method - I am just worried about my data possibly being erased though from flashing with this method though.

I have backed everything up on my phone but I would like to avoid erasing my phone unless absolutely necessary.

I will trial and error some stuff tomorrow (as its late here again) and let you know how it goes.

I might even try re-flashing my current firmware(A.0129) back to my phone to restore the system to stock, OTA update and then flash magisk and twrp back(if OTA is successful). This possible solution will be ok provided the next FP3 firmware update does not have this flashall.exe issue like with this one.

Once again thanks for all your help/suggestions

You mean because in the Linux “flashall” method mentioned on the Fairphone support page the dialogue is missing to choose if data will be erased or not? Or what do you mean with “much more directly”?

Using the flashall exe for windows or using the flashall script for Linux is basically exactly the same. But, just to ease your mind, I literally just used that Linux method to update my FP3, and no data was erased. Everything is still there.

2 Likes