English

Last updated, I'm stuck in sideload mode

I updated to the last versione of the OS but can’t switch on anymore. I managed to enter del fastboot mode but my pc doesn’t see the phone so I can’t try to manually upload the OS.
I have windows 10 and all drivers are updated.
I can only enter the recovery mode and not to lose my data I chose to try to use ADB for solving the problem. It seems I can see the device from platform tools, but I don’t know what is the exact command to sideload fp2-gms-19.11.2-manual-v2.zip
I tried with: .\adb sideload fp2-gms-19.11.2-manual-v2.zip but the result on the phone is:
Finding update package…
Opening update package…
Verifying update package…
E:footer is wrong
Update package verification took 0.1 s (result 1).
E:Signature verification failed
E:error: 21
Installation aborted.

How can I solve this problem?

You can’t side load the mentioned zip file. It can only be extracted and contains scripts and images for installation in fastboot mode.
Even if you seem to see the device in recovery but not in fastboot mode - did you anyway already try to extract the zip and start the manual installation batch contained in it (with your FP2 connected in fastboot mode to your Win 10 machine)?

3 Likes

Yes, I did… The system with my PC can’t see the device… I tried several times to enter the fastboot mode and launch the batch, but It doesn’t work. I tried even to update drivers but nothing happens. The device can’t be seen.
I tried also with another FP2 I am using for test.

I will try with a different pc, hoping to have a different result.

What Is It possible to do in sideload mode? It seems I can see the device only in recovery…

1 Like

Unfortunately I’m not aware of a way to manually install FPOS using sideload mode. Might be someone else knows…
You can install LineageOS or /e/OS using this method but this will probably not be helpful for you.

Can you specify what happens? Did you try other cables and are you def using a data cable? What happens when you try fastboot devices? Some user had to try it over and over again and at some point it worked.
In the device manager, when FP is connected with PC in fastboot, can you see something under “Kedacom…”
Did you unzip the folder before running?

I tried three different cable, now I can see the Device “Android”, I tried to upload all suggested drivers for Fairphone 2, even ADB drivers, but still couldn’t get a connection with the phone. I even tried with another PC, but drivers seems not to be enough for connection.
I don’t see anything like “Kedacom…” in device manager (only Android)

I will try with Linus by a friend, hoping then I can connect the device in fastboot mode and be able to launch the batch (the folder is unzipped).

Whick PC OS is the best to connect FP2?

I’m not sure why the FP instructions are asking to search for Android, so far I do not understand what this is for, other then causing misunderstanding.When you are missing Kedacom you are actually missing the driver you need. So to ensure: you connected the FP in fastboot mode to your PC, and searched under Windows Update for updates and then you had a look at “additonal” (or similar) to find the driver and you installed the Google Driver?

I never had any issues with windows, so not sure there is something like the best system

I think you should forget about ADB here in this case, you do not need this.

2 Likes

I wouldn’t be too strict with the name.
My Windows 10 Pro installed “LeMobile Android Device” automatically quite some time ago, and it works just fine since then.
If it’s Kedacom now, the automatically offered driver might change again in the future … whatever works.

1 Like

OK so far all Windows 10 user (probably not pro?) had Kedacom after updating the driver, and with this is worked with manual installation

1 Like

It’s also kedacom here on Windows 10
grafik

But it also works fine with Linux Mint.

2 Likes

Don’t have the phone connected right now, anyway …

grafik

1 Like

How do you see it if not connected, under hidden? Or is it just a dream that its only visible.when the FP is connected?

Yes, I enabled hidden devices to make it visible. I guess that’s also why there are so many seemingly identical entries, I think every phone I connect in a certain way gets its own entry.

1 Like

Does fastboot devices output anything? An what does fastboot --version output? Maybe fastboot on your PC is simply not installed, or too old?

I finally managed to see the phone on Linux, with the help of an engeneer. I can’t explain exactly the procedure followed, but we managed to see the phone and in Fastboot mode we firstly uploaded 19.11.2. That didn’t worked. We then uploaded to Android 9 and now everything works correctly. I managed to recover all data :slight_smile:

Thanks for helping

3 Likes

I actually think that you would not need to install fastboot for FPOS manual Installation, at least I’m 99.9% sure that I installed FPOS manually a year or more before I installed ADB+Fastboot

1 Like

That’s not possible, the installation script flashes images with fastboot flash, it can’t work without fastboot.

For this topic not relevant, but I still think that the way FPOS is installed manually is to make it possible for everyone and the instructions do not refer to installing ADB and fastboot upfront, so I still think its not required but somehow included in the script, else it would be a miracle how it worked in my PC without having ever heard a word about ADB and Fastboot commands, Plattform tools etc :wink:

2 Likes

Wording problem.
Some situations or guides on some OSes might suggest an installation of the adb and fastboot commands, when other situations or guides might not.

The “official” Android SDK platform tools don’t get installed, they just get extracted and used.

Some of Fairphone’s install files might bring their own fastboot command and use it.

Using a Linux packet manager or software manager will install the tools.
Using one of those Windows installers for ADB and Fastboot will install the tools.
(In both cases I don’t expect the install procedure to do much more than extract the tools and add their folder to PATH.)

2 Likes