Language layout of Bluetooth keyboard


I have problem using a separate keyboard (hid-keyboard). I manage to connect it but I can’t use Swedish letters. When I try to change keyboard layout, there isn’t any options, just Standard. Shouldn’t there be options?



I think this depends on your software keyboard. Have you tried to use a alternate keyboard with more options like SwiftKey?

That allows several layouts and if I’m right, the Swedish one should be one of it.


I got the same issue with an old bluetooth keyboard that connects correctly but sends default qwerty codes even though its physical keys are local to my language. When I bought it (very long ago) it came with drivers to be installed, and of course none exists for Android.

You should first check if your keyboard is supported somehow for Android: do they have a website with downloadable apps, etc.

It (like me) it is not supported, you may solve the issue with specific Android keyboard-remapping apps. I found one such app, but personally didn’t manage to set it correctly. I’ll try to come back with its name; maybe if you succeed I’ll be remotivated :wink:

[edit] I found it back, it was ‘External keyboard helper’. I hope you’ll learn to use it so that you can explain me!

1 Like

Thnx! The app did a good bit! I still have problem with letters but it could be my hardware.


Skickat från min iPad

Did you find indeed how to change one character with another?
I remember I tried various tricks but never managed to do it…

I just bought a keyboard for iPad mini, and with your app everything worked! I didn’t try to change characters, I managed it with the new keyboard.

Happy Christmas!


Skickat från min iPad

There’s also a free app, RaidSix, which works perfect.

It doesn’t install launcher icon; just go to settings > language & input > hid-keyboard > layout after installing.

So what, now.

I’ve installed RS - Hardware Keyboard Layouts and I don’t know what to do to set the external keyboard to AZERTY.

Where are the settings for the external keyboard ?

Thanks in advance.
Vincent, very happy owner of the community given FP1U, Android 4.2.2

  1. Connect external keyboard (otherwise settings don’t appear)
  2. Settings > Language & Input > Physical Keyboard > hid-keyboard > Set up keyboard layouts
  3. Choose French, it’s AZERTY. Sadly the layout is not spelled out.