Keyboard not working until I have wifi- can't have wifi because keyboard is not working

Hey guys!
I have the following problem: I installed the new fairphone version and now the keyboard isn’t working. I wanted to install google apps to make it work but it’s too big for my data roaming. I have to connect to wifi which I can’t do because my keyboard doesn’t work.
Do you have any solution?

Is it because your Google Keyboard stops working? I have the same problem.

You can go to your settings and change the Google Keyboard to the Android Keyboard.This one did work for me. But since then, I get a “Google keyboard stopped”-message every time I use my keyboard, even after installing a whole new keyboard…

Actually it sais that the Android keyboard has stopped working… and if I search for a solution on google it tells me that I have to reinstall google apps which I can’t do because I can’t type in the wifi key.

So maybe you can use the Google Keyboard instead?
Otherwise, maybe you can connect to WiFi this way: No button to connect to wifi It’s indeed frustrating not being able to get internet access to solve the problem!

How can I switch to the google keyboard? I can’t find it…

And the router doesn’t have the wps button :frowning:

go to settings => Language. There you can choose your keyboard. Or: there you should be able to do it…
Good luck!

And otherwise, maybe you have a backup? Or, in the worst case, maybe you should downgrade again?

If it’s your router, you could disable the password, DL what you need, and enable the PW again.

I had the same problem! Couldn’t install Google Apps because it wasn’t connected to Wifi, but to connect to my Wifi I had to type in the password, but that wasn’t possible without a keyboard. But to get the keyboard you needed google apps…

Anyway, if humorkritik’s tip doesn’t work, I had someone make a hotspot of their phone without a password. That way I used their hotspot to download google apps. Not the greatest option though. (used a lot of their internet hehe).


No coffee-house of fast food ‘restaurant’ near you where you could have used an open WiFi? From this, I would guess, you must be living in Germany, land of the digitally insane politicians. :disappointed:

However, since it worked, it might be a feasible way if @NoraAron can’t disable the PW on her/his router: create an open ad-hoc WiFi with another device which is able to connect to the router. :smile:

Hey !
Thanks for your answers :smile:
I went back to my parent’s house, my father uninstalled the wifi key, I downloaded google apps and can now use my keyboard again (thank God!)

Thanks for you help!!


Oh and yes: Germany. Not the best free WIFI country :confused:

I like it when people come back to say thank you. :heartbeat:

FTR, I travelled quite a bit in the past, and Germany is the worst free/open WiFi. I’m really glad that “Freifunk” exists, and I’m happy to promote it. Try it, it’s quite save to offer Freifunk yourself. All you need is 15€ equipment and someone who’s technically gifted enough to set it up for you. :sunny:


I’ll keep it in mind :wink: Yes…you would think that such a developed country would be great with internet usage… but it’s pretty bad.

1 Like