Keeps asking which launcher to use

I also confirm that it’s been 1 full week since I disabled the automatic schedule of the bedtime mode and I did not see this issue again.
Well done guys and thank you!

4 Likes

BTW if anyone finds a way to keep the bedtime mode scheduling, feel free to share your findings. For the meantime I’ll make do and rely more on myself for self control :wink:

2 Likes

Sounds like the way to be
:om:

1 Like

I have had the same problem for a few days now. Annoying, but not that bad.
Great to read this forum and find out a possible solution. I initially thought it was Firefox causing the problem, but apparently it is digital wellbeing.
Let’s hope it is over now.
Thanks for sorting out a solution!

1 Like

Having this problem here too. Microsoft Launcher.
Have tried uninstalling and reinstalling. Still happens.

You mean the launcher ?

Have you not tried disabling the Well Being app ?

5 Likes

Thank you very much! Since deactivating digital wellbeing everything works smooth again, yay :v:

4 Likes

I noticed the issue happening today again. I groaned “I hate this phone, why did I buy it?” audibly out on my daily walk.

Then I realized I hadn’t frozen Digital Wellbeing in my work profile. I froze it and like magic I’m back to the phone being awesome again.

So yeah, this is 100% Digital Wellbeing not living up to its name. Or maybe this is intended? After all, if we hate our phones we spend less time with it

#conspiracy

5 Likes

Aaand it’s happening again even with Digital Wellbeing frozen on both profiles. Why is this happening to me :frowning:

Anyone have any other ideas?

You say frozen, do you mean disabled. You can of course uninstall the app to assess if is the source of the conflict.

I froze it with Insular, a phone management app that gives you an isolated work profile with the added feature that you can “freeze” apps essentially preventing them from running.

I tried disabling Digital Wellbeing instead of freezing it. We’ll see if it keeps happening or if this fixes it.

What fascinates me the most about this issue is that it happens out of nowhere for 2-3 days and then it goes away for upwards of a month.

2 Likes

Freezing in the isolation seems to be not enough. Disabling it helps.

By the way, not only the FP3 is affected, it also happened on the FP2. Solution for FP2 is the same; just disable Digital Wellbeing.

3 Likes

Sharing some links I’ve found in the previously linked Reddit thread:

AndroidPolice article for this: https://www.androidpolice.com/digital-wellbeing-third-party-launcher-doesnt-stick/
And a GitHub Gist someone made about this also: https://gist.github.com/bengalih/ee939232fcde3c22516134e10cabbf11

I can reproduce the same issue when having two launchers installed and having the latest Digital Wellbeing update installed

I PackageManager: Result set changed, dropping preferred activity for Intent { act=android.intent.action.MAIN cat=[android.intent.category.HOME] flg=0x100 } type null
I ActivityTaskManager: START u0 {act=android.intent.action.MAIN cat=[android.intent.category.HOME] flg=0x10000100 cmp=android/com.android.internal.app.ResolverActivity (has extras)} from uid 0

I believe this must be fixed on Digital Wellbeing side, I don’t see any changes in AOSP Gerrit or LineageOS Gerrit that could change this.

7 Likes

#!/bin/hi *

I also started suffering from this problem in August 2022 (FP3 - Nova Launcher). Next, the phone’s performance started deteriorating up to unusability, e.g. waiting for the keyboard to appear in Signal for about 5 seconds and massive delays between keystrokes.

Ripping out Digital Wellbeing as described in https://sergei.nz/remove-googles-digital-wellbeing-spyware-from-android-via-adb/

adb shell pm uninstall -k --user 0 com.google.android.apps.wellbeing

brought immediate remedy and my phone works great again. Digital Wellbeing is gone (not disabled or frozen: gone). However, it might get unintentionally reinstalled.

If that’s really the case, then forcing a misbehaving app (Digital Wellbeing) on the phone, which messes up my phone is a clear 10 out of 10 on the Suck-O-Meter.

6 Likes

The problem is gone with the latest version of the Digital Wellbeing app released earlier this month.

5 Likes

Huh, fascinating. After installing the August update this issue happened even with Digital Wellbeing being disabled. It stopped happening shortly afterwards.

I have no idea how Digital Wellbeing is interfering with the Launcher, but IMO an app shouldn’t have the privileges to do that. But then again, this is Google we’re talking about.

Hi
i suffer the same issue since august
i’m using Microsoft launcher, and i don’t have the application " Digital wellbeing bedtime" so i cannot solve it the way you did it

any other user solved this issue ?

ho i found the app it’s called “bien etre numérique” in french
i disabled it.
let’s see if this occurs again…

This happened again just now. Digital Wellbeing is disabled. It happened after I locked my work profile with Insular. Hmm.

Edit: unlocked my work profile and it’s still happening. Hmm!

1 Like