K9-Mail on FP3: Push works only for Pop3- not for IMAP-Accounts

Dear people,
I’m a teacher and because of Corona I need to be within easy reach via mail for my students. I’m using K9-Mail on my FP3 and cannot find out why the push-notifications on new mail don’t work. In K9 I have two Accounts - a private one with SMTP and a workmail with IMAP. When I get a new Mail on my SMTP-Account I get an push-notification. Sadly not the same is happening for my workmail with IMAP.
Anybody an idea why this is happening?

Is battery optimization disabled for k9? I have imap inboxes, and they get notification (with phone off)


I’ve already disabled the Battery-Manager completely in Settings > Battery. Is there an other thing to do?

Yes, if you go into settings, apps and search for k9, there’s an entry Battery optimization. There you can switch between optimized and not. You should choose not optimized


I’ve done that, but there are still no Push-Notifications for the IMAP-Account :confused:

A few ideas
Check in settings, where the config for getting messages is. There is an option to renew push tokens (minutes)

Also, if everything else fails, you can use the polling option


Use k-9 mail version 5.600. In the newer versions push is disabled at the moment, see this issue.


I’m using Version 5.600 already. But thanks for your help!

F-Droid has the K-9 forks SimpleEmail and FairEmail, if you want to try.
FairEmail explicitly lists “IMAP IDLE (push messages) supported”.


Yeah that works! Great!
Thank you!

1 Like

SMTP is a protocol to send e-mail, not to receive it. Did you mean POP3?


You’re totally right. I’ve been in a hurry and mixed it up.
I’ve edited the title. Thanks for your hint!