January 17th sale is over. Next batch comes in March

It’s 17/01/2018, but the FP online shop is still showing the “Back in stock on January 17, 2018” message. At what time is the online shop supposed to open? :wink:

I’m still a proud FP1 user, and even though my dear old FP1 is still working great, I’d really like to try the new FP2… I thought the latest batch would be available on January 17th, as announced, it’s 00:33 CET and no change on the online shop.

After missing the opportunity of buying a refurbished FP2, and having saved 529€ for the new one, I really don’t want to miss this one.

Please, the next time you write a date for the following launch, be more specific and also include the time. Thank you!

Oh well… luckily I have to get up early… in a few hours :sleeping:


I would not expect it to become available before 10 am (CET) at the very earliest (this is just my personal guess based on this):

Screenshot-2018-1-17 At what time (GMT) will the new phone be available - Christian Addington

Actually I would not be surprised if it was closer to noon.


Right now (January 17th 2018, 10:45 am) the website is down for maintenance.
My guess would be, that @urs_lesseless was absolutely correct with his guessing.

As soon as the website is online again, the phone should be available.

Well it was already theoretically possible to order but the site had so much traffic that it didn’t load anymore. Guess that is the reason for the currently shown Maintenance page.

I wish Fairphone would just take orders no matter if the device is currently available even if I had to wait half a year for delivery it would still be better than now.
The way it is handled now ordering a Fairphone2 is mere gambling.

Anyone who loses at this gambling can still check frphn.co/stores to buy/order an FP2 elsewhere. I did so in December without problems.

Don’t let yourself be fooled by “store” in the URL, it also includes online-shops that ship to the whole of Europe.


For months I’ve been waiting for the oppurtunity to order a Fairphone2. Today was the day… I tried to order time after time, but couldn’t get my order through (Gateway Timeout). And now the shop is “down for scheduled maintainance” (duh!)
I don’t have a smartphone yet and I really wanted a Fairphone, because of the philosophy it is based on. But I absolutely need a smartphone for my voluntary job, which starts early February.
This way you almost force me to buy a commercial phone instead of the fair and honest one I wanted…

1 Like

You can always try http://frphn.co/stores to see if there is a store near you.

That site also lists online-shops and some ship Europe-wide.

You don’t really depend on buying at Fairphone itself (as long as the FP2 is in stock for the other shops of course…). I ordered at Vireo in December and got it one week later.


For everyone not already aware, the latest updates can be found on Twitter.


Strange, whenever I click on “Add to Cart” I get the error "The product “Fairphone 2” cannot be added to cart."
Have already tried FF and IE without any luck. :frowning:

Hey all, we had a lot of technical issues with the website today.

But they seem to be solved and phones can now be ordered.

Sorry for the inconvenience.

1 Like

Oh yes, very very strange.
Das Produkt “Fairphone 2” kann dem Warenkorb nicht hinzugefügt werden.
Hope for the best.

That is strange. Can you empty your cache and/or try the incognito mode in your browser?

No still not possible to add to Cart. Even tested it on a different PC (Win/Linux).

I have no issues adding stuff to cart here (Linux; FF/Chrome).

1 Like

Works for me, too. Just ordered 6,500 FP2s.


No, I did not. But I was able to add FP2s to the basket.

Firefox, MacOS 10.11.6

1 Like

Please remain logged out of your user account until the end of the ordering process. That might help.


finally, this worked! Thank you a lot for the tip to stay logged out :slight_smile:


Yes, that helped.
Not been logged in until the Website wants to know, who you are.
FP2 ordered and paid immediately.
But, …
Why does it not funktion beeing logged in?




Same here. Ordering while logged out did work.


maybe I am just blind but I cant find this info on Twitter could someone who owns an account just comment this post:

Think there are still some desperate people out there…