It is about configuring a travel router (Gli-Net mt-3000) with my FP4

I have purchased a travel router, which I wanted to use during my holidays. Unfortunately I was not able to configure it. This is how I proceeded:

  1. My FP4 needs to have an ip address belonging to the subnet of the travel router I therefore switched off my simcard.
  2. I tried to connect to the travel router via wifi, having no usb-c-to-lan cable. After having entered the credentials the FP4 connected to the travel router for a very short time. The FP4 then showed me that it didn’t have an internet connection and stopped all of a sudden the wifi connection to the travel router. With the result of me being unable to configure the travel router. I was not able to use the travel router, which I had bought for that occasion.
    My questions are: How can I circumvent a similar situation in the future?
    Am I supposed not to use my cell phone to configure a travel router? Am I supposed to go on holidays with an extra computer?
    Why does my cell phone not behave like a computer? I thought smart phones are called smart, because they behave smartly. Apparently they don’t.
    I certainly have missed something as far as my FP4 e/os is concerned.
1 Like

So travel router means a router with SIM Card? Why not just bying a travel SIM and insert in the FP4?Why do you know the FP4 and not the router disconnected?

Edit: So I just connected to my companies LTE mini rooter without any issues and use the internet to write this edit to the my message.

Same question, what do you mean by “travel router”?
Anyway, no need to switch off your FP4’s SIM card: Just enable WiFi, and it will connect through that, like it is supposed to.

As for the router, connecting to the router’s administration GUI, once connected to your router’s WiFi, check your phone’s network settings to find out where the router lives.
The command is “ifconfig” if you got access to a terminal, else just check settings: What you’re looking for is the thing called “(Default) Gateway” (which is geek talk for the address of the device that connects you to Internet).
You should find something like “Default Gateway =” (the IP you gave above is wrong, IPs only have 4 groups. I guess your address is or

The Internet Assigned Numbers Authority (IANA) has reserved three blocks of the IP address space for private intranets (not public networks):        -  (10/8 prefix)      -  (172.16/12 prefix)     - (192.168/16 prefix)

Your router, like all SOHO routers, uses the /16 prefix addresses, so its default IP is most likely 192.168.x.1 (where x is a number from 0 to 255). This is important because it hosts a web server, which allows you to get to the administration interface.

Fire up your phone’s web browser and enter as URL: http://192.168.x.1
This should bring you to your routers login page.
From there I guess you know how to continue. You need the administration login, often on a sticker on the device itself. Change it ASAP, else anybody can access it…

All this is easier with a full-fledged computer but definitely doable with a phone.

Edited to add:
Just noticed you actually gave the model in the title. -facepalm-
How is this a “travel” router? A portable firewall more likely. Saying that because there are real “travel routers”, which do not need a WAN to connect to, since they connect using wireless, having their own SIM card (much like the phone’s hotspot feature). Very convenient for sailboats and mobile homes.

After it says there is no internet connection, an option will appear that lets you stay connected.

1 Like

Thank you for your quick answers. Apparently I did not explain exactly enough what my problem was.
What people call a travel router - at least on Amazone - is a device which gives me full access through vpn to the internet. It does not have a sim card. It just establishes a secure connection between my FP4 and my internet router at home.
So I connect my FP4 to the travel router via wifi, the travel router connects to the router of the hotel. But for that the travel router must be configured to connect to the wifi of the hotel. When my FP4 is connected to the travel router I can call its web page in order to configure the travel router’s connection to the router of the hotel. But that only works when I switch off my sim card. If I don’t do that my FP4 gets a routable internet address from my sim card provider and I cannot login on my travel router. If I switch off my sim card, the FP4 connects via wifi to travel router, that is it gets an internet address (not routable: But as the travel router has not yet been configured for the wifi access to the router of the hotel, from where it should get a routable internet address, my FP4 shows me that there is no internet connection and it cuts the connection to the travel router. With my sim card switched on I fire up my web browser, enter the ip address of the travel router, and apparently the browser can’t find the ip address, because via the sim card the FP4 gets automatically a routable ip address, but it does not get an ip address belonging to the same subnet as my travel router. The same thing happens whith my installation at home: I connect to my home/internet router without any problems. When I inspect my network I can see that my phone has one routable internet address and a non-routable lan address ( The ip address of the travel router, however, is All my inquiries have made me realize that I cannot connect from to So there does not seem to be a solution for my problem. When I use a computer to configure the travel router I do not have these problems. I can connect to my travel router, the computer stays connected and I can finally configure my travel router for the wifi access of the hotel.

You do not need a router for this: Just install the VPN client directly on your phone…
Just check with your VPN provider, I’m willing to bet they have an Android client.

No. Your phone, any phone, will use mobile data (if enabled) to connect to Internet, unless there is a valid WiFi connection it can use.
In which case it will use that one, even if it has mobile data enabled.
It has been thus since the very beginning, given that mobile data used to be eye-wateringly expensive and people preferred using their (already paid for) home/office WiFi connections.

So: Either just connect to WiFi, your phone will ignore mobile data, or, if you’re really paranoid about it, you can disable mobile data (in the draw-down menu on top). Definitely no need to switch off your SIM card!

Besides, “mobile data” and “WiFi” are two different and independent network interfaces, each having its own, different IP address. But if you really want to be sure, disabling mobile data is just a click away.

Okay, now that sounds indeed like a real problem, albeit an odd one.
I’m not at home and thus don’t have any router I can unplug to test, but it definitely seems strange to me. I didn’t notice my FP4 disconnecting from WiFi when Internet is down for some reason. After all, the WiFi network connection is between the phone and the router, and where/if the router routes it afterwards is irrelevant for the WiFi connection. To illustrate, your router could be a local server for instance, no Internet to be expected ever…

1 Like

Obviously I am still unable to explain my problem. I will try once more:
When arriving at the hotel my FP4 is not yet configured to use the
hotel’s wifi. When I switched it on, it automatically gets an internet
connection with a routable internet address. Am I right? At least my
cell phone did behave like that. The next step is: I want to establish
a wifi connection to my travel router, because I don’t want to use the
hotel’s wifi connection. I try to establish a wifi connection from my
FP4 to my travel router. The travel router is switched on, my cell phone
finds the wifi connection to the travel router, I enter the credentials
and the connection is established. Unfortunately I cannot login to the
web site of the travel router in order to configure it. The only reason
I could see was that my cell phone did not have the necessary lan ip. I
can only speculate about the reason. May be the travel router’s dhcpd
was unable to distribute any addresses.
I then tried the following:
I switched off my sim card (recommended by the travel router’s support),
I established a wifi connection to the travel router, I got a lan ip
address, could log in on the travel router, but only for a short time,
because the FP4 cut the connection not having found an internet
connection. I thus was unable to configure the travel router. If I had
had my laptop with me, I wouldn’t have had these problems. Under certain
circmstances my cell phone does not seem to behave like a computer,
which works in a wan as well in a lan, without asking for an internet
connection whatsoever.
I certainly seem to have misunderstood something. Furthermore - as I
have already written - I am unable to make me understand. Having talked
with it specialists back home, I had to realisze that I was not alone
with my problem. But the specialists could not help me either, because
the problem was not new to them. They just hadn’t found a solution yet.
I am really thankful for all the help I encounter here, but sometimes I
get pieces of advice which I realy don’t need. Excuse me to be so frank!
I know that I can establish a vpn connection via the FP4 directly, but
if my friends, my relatives want to use also a secure connection, I must
give them the credentials of my vpn???

So the conclusion is, its not a Fairphone issue or what does that mean exactly?

And does the router need to be configured with every single new network?

I see what you’re trying to do, and I don’t think it is impossible to log in to the admin interface of a router without internet from the FP4. I have configured OpenWRT from my smartphone as well, and my phone happily stayed connected - anecdotal evidence! That was with stock android, did you mention that your phone is running /e/ OS?
Either way, keeping your SIM card disabled is required as you say, otherwise it’ll fall back to your mobile data. A few other things perhaps worth trying:

  • In developer options, there’s a setting along the lines of “limit WiFi scanning”. Sorry for not knowing the exact name, my phone has a Dutch interface. Try turning it on. I’ve found that this scanning for other networks is sometimes the reason that it drops the existing connection.
  • When you are connected to the WiFi network, press the gear button next to it and look at the IP address that’s been assigned to you, and perhaps more importantly the “gateway”. This gateway is where you should expect to find the admin interface. If “Gateway” says, then hooray, your manual was right. Otherwise, try going to http://[that gateway address] instead.

Two final words of caution. Firstly, a lot of hotels have open/unencrypted networks that present you with an authentication webpage that may require you to enter your room number or just accept the privacy policy. They may even require you to reauthenticate every half an hour. I don’t know how you would go through this authentication from your router. The trick seems to be to first accept the terms on your phone or laptop, and then have the router connect to the hotel network with the “spoofed” mac address of the device that you used to accept the terms. This probably requires you to turn off mac address randomisation on your phone or laptop before you do the authentication.
Secondly, bear in mind that most wifi radios are incapable of both connecting to a network and being a access point at the same time. Now you might be lucky that your device is dual-band; you may be able to use te 2.4GHz band as your WAN port connecting to the hotel network, and then set up your access point on 5GHz. However, from experience this is far from trivial to configure in OpenWRT. It might be too late for this recommendation, but I would definitely try setting an hour or two aside at home before you set off on your trip to configure the router the best you can. Pretend that your own home WiFi is the “hotel network” and make it work. This is going to take some fiddling, some trial-and-error, and is a lot easier to do from a PC or laptop. But once you’ve done the fiddly part at home, once you’re on holiday your only worry will be to connect your travel router to the hotel network.

1 Like

I’m quite sure this happens because every Android device uses captive portal detection (to check internet connectivity using the WiFi network - and switching back to mobile data and showing portal notification when it’s blocked like in your scenario).
Using a quick internet search you’ll find suggestions about how to disable captive portal detection).
As an alternative to using ADB you might try out the following:

1 Like

That’s it. I switched off gogle’s captive portal.My cell phone now
connects to “” (see
Android Captive Portal Check: 204-HTTP-Antwort von ⋆ Kuketz IT-Security Blog).
And it behaves as I expect.
I am quite happy.
Thank you very much.

1 Like

That’s it. I switched off gogle’s captive portal.My cell phone now connects to “” (see Android Captive Portal Check: 204-HTTP-Antwort von ⋆ Kuketz IT-Security Blog). And it behaves as I expect.
I am quite happy.
Thank you very much.

PS: One last word. I am very much surprised. I am on e/os and was expecting to have a “degoogled” cell phone. Which apparently is not the case. And what is even worse: most people don’t know anything about that. Myself is the best example for that. Fortunately there are “understander” in the community out there.

Don’t worry. It is the case. That’s one of the “degoogled” features that /e/OS phones use a different portal check server (not a Google server) but the same feature (although at the moment I can’t find a proofing source for that).

1 Like

Would that not be something Kuketz would mention in his OS check reg DeGoogling?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.