English

Issues with apps after updating to Marshmallow

Hi there,
Sorry if someone asked this already but I search and I found nothing.
I updated today to Marshmallow and everything seems fine. Before I had a 128 GB microSD card that wasn’t recognise by the phone. After the updating it recognised the card at the end so I was ultrahappy. It asked me and I chose the Internal memory and it was formatted ok. The phone was much faster now. The problems arrived when I tried to send a voice note in Whatsapp. It pop-up a message saying “To record a Voice Message, allow WhatsApp access to your microphone and your device’s photos, media and files. Tap Setting > Permissions, and turn Microphone on and Storage on.” and the choices “Not now” and “Setting”. I chose “Settings” and then “Permissions”. I click on Storage but another message: “Screen overlay detected
To change this permission setting, you first have to turn off the screen overlay from Setting > Apps” and the choice “Open Settings”. I click “Open Settings” and chose Whatsapp. In “Draw over other apps” the option “Permit drawing over other apps” was off but in grey so I couldn’t change nothing but it was off anyway… After a lot of trying I clicked in the three vertical point in “Draw over other apps” and chose “Reset app preferences” and many apps disapparead, including Whatsapp. But the same thing happen with many other apps, for example Skype, that stays in “Draw over other apps” after reseting preferences. It told me I have to turn off the screen overlay and or I did it and it didn’t allow me to give permissions or it was already off and I couldn’t give permissions.
Any idea? It’s really frustrating because I can’t almost use any app properly. Sorry if my explanation was strange but I tried my best to explain. Any doubt just ask. Thank you for you help and kindness.

Sorry I didn’t read your whole post (the formatting gave me a headache), but I think your main issue was already reported here:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.