Investing in long-lasting design: Android 7 for the Fairphone 2

I did the same, but TWRP keeps downgrading to version 3.1.1 when I boot the system normally, then boot it again in TWRP. I had the same problem with the old FPOOs. But now at least, the version it gets back to, is a version that lets you do backups from an encrypted phone.
Does your phone stay with version 3.2.3?

Intersting topic and interestin workaround.
I had the following: updated FPOOS (new camera module)
1st time shutting down my phone: reboots immediately
2nd time: shutdown with flashlight on: phone stays off
3rd time: shutdown when charging: phone stays off
4th time: shutdown when charging (very low battery level, around 5 percent): phone reboots immediately
So there’s no clear pattern yet, I’ll keep an eye on the topic.

After you flash the new TWRP, directly reboot into TWRP to let it make itself resident, don’t directly boot the OS as this way (as you found out) the OS restores its own recovery.

1 Like


No luck for me since version 18.02.1 the updater is not working properly so here I am like you one of the choosen to upgrade to Android 7 with an updater down. The unsolved problem is that when I click on the available 18.10.0 upgrade page in the updater nothing happens.

Congrats on getting there :slight_smile: The post makes it really clear why this is important. Looking forward to the update :slight_smile:


This is a known issue, still in progress:


Are you on Wifi (i.e. not mobile data)? (Updates only download on wifi)
If you’re using regular Fairphone OS, is the google play store working normally? (the updater itself is updated via play services)
Is the ‘download manager’ app enabled and can it connect to the internet (i.e. check your firewall if you have one)? (the updater uses download manager to download updates)
Have you already tried to clear app data for the updater app?

Thanks!! That’s what I missed :wink:

Thanks for your answer. But I’ve already tried that. When booting directly into TWRP after the update through TWRP, I get the new version. Then I boot the system, and the next time I’m back to TWRP, I get back to 3.1.1. It’s not a major issue, as backups are possible, but I was just wondering, whether there was someting I was missing out on…

1 Like

That’s odd, several users have updated TWRP successfully already.
When the new TWRP started, did you “Swipe to Allow Modifications”?

I installed the update the day before yesterday and lost all my data of the internal storage :frowning:
I had FP open installed, the new cameras in and the internal storage encrypted.
When it restarted I entered my PIN and the phone said it was wrong, then I entered it again and it stated that the PIN is correct but the data is corrupted and left me no other option as to reset everything.
I did not bother to backup everything before but have many things synced in some way so this was not too bad, the only thing I definitely lost is my Threema Account because the password I stored in my password manager for the Threema Backup seems to be wrong :frowning:
I was surprised how quickly the update worked but on the other hand I spent several hours to restore all the settings, apps, accounts and data.

Open Android updated and no problem with shutting the device down. Install very smooth, thanks for the nice work


I had serious problems, had to go back to FP Open 18.04.1
Phone was on FP Open 18.04.1, rooted and encrypted, using twrp recovery.
After installing 18.10.1, I had trouble with some apps using root access. ViPER4Android FX ( would not recognize the root access, my CyanogenMod file manager (version 3.0.0) crashed when trying to open the general settings menu to check the root access.

I had no problems with the torchlight, and was able to install the current version of the Xposed framework (89).

/system/app mover did not work though; an error message told me that it was not able to remount /system.

After a few attempts to reinstall Viper via twrp, the phone crashed, and I wasn’t able to restart the system; it only rebooted into recovery. Since I could not reinstall some twrp backups I had made when switching to FP Open, I had to manually reinstall the last stable Open 18.04 version…
Fortunately I didn’t loose any data, just a few hours to get everything back in place…

I’ll probably wait a bit before trying again.:disappointed:

Another happy camper here. Updated to FP Open 18.10.0 (no GAPPS) and everything went smooth. A few new touches in the UI, but everything else really stayed quite the same. All of my applications that I tested still work, no loss of data, no trouble shutting down or rebooting (old camera module). The occasional spontaneous reboots are still there (never bothered me much), the occasional connectivity issues as well. Battery life looks similar to Android 6…

From the little I have seen so far, my FP2 really seems to have remained very much its own self: a little quirky and otherwise simple and solid.


Hm, I think this only showed up the first time I launched TWRP. And then yes, I did “swipe to allow modifications”.

My device with FPOOS and new camera modules can also shut down only when the torch is turned on.

But the upgrade went smoothly and all other seem to run well yet. So thank you Fairphone for your great work!

1 Like

I am under the impression it is mainly FPOOS users that got the update, at least based on the report of forumers. Not so random after all?

Thank you for the upgrade I believe this is very good for the image of Fairphone. However, the Decision by management NOT to include the switching off of a SIM card is in my view a deterioration of one of the features of Fair Phone 2 and the new Nougat (7 - OS 18.09.2)software. You can still use 2 SIM cards no issue there but in the previous software version of Android (6.0.1) one could switch one off. Especially if you want to switch of your work SIM over the weekend or switch of the SIM you use on other continents is no longer possible in the updated version. So be aware if you need this feature to not to update to the new version. Just a warning to inform others….Thank you.


Not much of a decision … the feature is just not there in Android 7 by default, and it is uncertain whether Fairphone will be able to add it themselves.

“Regarding disabling SIMs: This option is indeed not available on Android 7. Currently we cannot say if we will be able to bring back to feature, but for sure it will not be included in the first official Android 7 release for Fairphone 2.”

1 Like

I guess a fairly high number of (active) forum members are FPOOS users, compared to the general non-forum FP-users :slight_smile: