Internet very slow/ not working on FP2

For a few month now my internet is working very slow (edge) and sometimes doesn’t even work at all. I have tried everything but nothing works. When I put my sim card in someone else’s phone it works just fine so it has to be the phone. Wlan works fine as well.
I contacted fairphone support but they were not help and suddenly stopped answering.
Has anyone had similar issues and could help me?

1 Like

Which cell phone provider are you using? Can you confirm that your APN settings are correct and according to the ones your provider has specified? Is there any proxy configured in your APN settings?

Do you use the Dual-SIM functionality? The Fairphone 2 only supports high speed mobile internet on one of the two SIM cards, the other one will be set to EDGE (2G) only. You can configure which SIM slot should be the slow one.


Yes I did like 3 factory resets already. It could be the antenna, I will have a look at it thanks! It does look complicated though is there a piece that I could buy to replace it?

Oh wow! That was so simple!! I just took one of my sim cards out and now it works perfectly fine!! I had tried switching the slots before but that hadn’t changed anything.
Thank you sooo much!!! I can’t believe it haha


That’s great! :slight_smile:

You can read more about the dual sim feature here.

Set the preferred network type (2G/3G/4G)

There can be only one SIM card connected to a high-speed network type (3G/4G). To define which one:

  • go to Settings > More > Mobile networks
  • define, per SIM card, which network type you would like to use
  • switch a SIM card to a high-speed network type (4G (preferred)/3G/2G or 3G (preferred)/2G), by making sure that the other SIM card is set to operate on 2G only

You should be able to use both SIM cards and set one of them to 4G and the other one to 2G only.


@Douwe While this limitation is kind of known to more frequent forum readers, the user guide doesn’t mention it (at least the English and German one doesn’t).
It only says one should have a look at the Dual SIM settings and where to find them, but it is not the first time a user simply didn’t expect such a limitation at all.

Can’t this be added to the user guide?
(I know, nobody reads that anyway, but we could easily link to it :slight_smile: )


Thanks, indeed I checked the preferred network type put had 4g for both. I guess that was the reason.
Thanks again!


I think that would be a good idea :slight_smile:

Another solution is to select: Settings > Wireless & Networks > More > Mobile Networks > [second SIM card] > Preferred Network Type > 2G
For the first SIM card you can then select 4G instead of 2G.

On a side-note:

  • As long as the second SIM card has 4G selected, 2G will be your only choice for the first SIM card and the menu option will be greyed out / disabled.
  • The factory setting for both appears to be 4G. So if you ever set the first SIM card to 2G, you will not be able to switch it back to 4G, without the reason being obvious to the unsuspecting user.
1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.