Installing Lineage OS : no devices/emulators found with adb

Hi there!

I am very happy to get my freshly acquired FP2 in hands, and wanted to start properly by installing Lineage OS on it instead of going further with Google OS, but I find some difficulties in doing so. I saw other people faced similar troubles, but couldn’t find a proper solution so far (I am trying for quite a few hours now…:sweat_smile:)

So I tried to follow the nice guides I could find about it on this forum, and had some difficulties in installing adb, because I couldn’t understand how tocomplete this step : “Add the following to `~/.profile” so after checking so forum and the web… I decided to try the installation of adb using homebrew, it seemed to work.

I can use adb commands. But when I connect my device (USB debugging is enabled), I don’t find my device in the list, and therefore cannot continue. I tried all my 4 USB ports, without success. I’m using a Mac OS 10,14 computer.

Is there anybody who would have an insight? I have no experience in Terminal using and OS-installation related topics, but will do my best to figure it out!

Is there a Fairphone angel or event near you? It might be possible to get some help in real life.

Other than that: are you sure the USB cable you used is capable of transferring data? A charge-only cable will not work (I lost several hours once because I wasn’t aware of that there are two types of cables).


Hello @Ingo, thank you for your quick reply. The issue may come from the cable, I brought it back from work. Is there a way to check the cable type, for now or in the case I would need to get a new one? I’ll try with another cable I found there.

I live in Paris so thanks for the Community Map, I see there is a contact for this location, I may use it if I can’t solve the problem with the cable tonight.

Actually I don’t know if it’s possible to find out by looking at the cable itself.
I tend to check by using it to transfer photos from the phone to the computer. If that works, it’s obviously a data cable :wink:

1 Like

Dear Ingo, thank you for your help, it came indeed for a silly cable issue… I got another one and did eventually manage to install Lineage OS on my FP2. Thanks a lot!


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.