Installing FP2 OS to replace lineage, now it doesn't boot

Hello everyone,

I recently installed lineage OS by following the tutorial here.
Now I want to go back to FP2 OS (fp2-gms-19.05.3-manual), wiped everything with TWRP and then followed the instructions from the readme file found in the FP2 OS download, but after rebooting the phone just stays with the animated boot logo forever. I reluctantly tried “fp2-gms-19.08.1-manual”, too, even though the last time I had it installed I couldn’t connect to any W-LAN, but with this one the boot process didn’t finish either.

I already managed once to go from FP2 OS to lineage and back, following the respective tutorials, but now the procedure doesn’t work anymore and I don’t know what I’m doing wrong. Is there any way to get a boot with console output so I can at least pin-point the problem better?

I am slightly suspicious of the installation speed, because it barely took a minute to go through the entire “flash-for-windows.bat”-file. The script said everything was fine, but I’m still wondering if that was normal.


It may not cure your problem, but when I switched a lot between Ubuntu Touch, Sailfish and FP(O)OS, I sometimes ended up with a phone that didn’t boot. It seemed that flashing a new OS really stresses the devices and it gets pretty hot. Maybe it was coincidence, but letting it cool off and then later installing the FP(O)OS always did the trick for me.


For what it’s worth … LineageOS builds will be back soon are back …

If all else fails …


@Ingo Okay, I could try that again

@AnotherElk Thanks, but if I plan to send the phone back for repairs, is it ok to have lineage OS on it or should I find a way to reinstall Fairphone OS? Because that’s why I tried it.
Also if I read the thread correctly, I think I already did all of that. I followed the tutorial that tells me how to install lineage OS (see link above), but instead of installing lineage, I just went back to fast boot and installed fairphone OS, using the bat file.

Good point … They only support their OSes, so either they would expect the phone to be on Fairphone OS or Fairphone Open OS when it gets sent in, or I guess they would install one of those themselves.

1 Like

Before sending it back you’ll have to create a ticket with FP anyway. So I’d recommend to ask this question to support in this ticket…

1 Like

Good idea, thanks, I’ll do that.

1 Like

Guys, I got another problem:
I just reinstalled lineage OS and noticed that my lock pattern was somehow still there, even though I completely wiped the phone twice. Once for installing FP2 OS, then once again for installing lineage. It seems like the wiping doesn’t work properly anymore. I wiped everything I could. What am I doing wrong?

Lock pattern for encryption or for the screen lock?

A pattern/PIN/password for encryption can only be removed by formatting the data partition. Wiping would not be enough.

In case of the screen lock … did you install Open GApps? I seem to remember that the method to unlock the screen would be synced with Google and would be reinstated by Google upon boot even after wiping the phone as an anti-theft measure … you would have to deactivate or unregister this online in your Google account.
I don’t know the details, I don’t use this feature. I will look whether there’s some post on this …

Okay, I meant I formatted everything. Yes, I used the GApps one.

Sadly my Network doesnt work. I try to actuvate it but it deactivates again.

Hmmm … could be I’m confusing something, but anyway, what I mean is described at the end of this page, section “Google security feature” …

Hm, no, I did not have to give any login information. The pattern was still there and even Telegram was there, too. I remember installing it the last time I had lineage microG installed.

But I swear I deleted everything in TWRP before installing a new OS. Maybe my TWRP is broken and it didn’t delete anything afterall? Or do I have to both wipe AND then delete everything?
Anyway, this would explain why my FP2 OS failed to boot I guess, if the deletion process didn’t do anything.

TWRP 3.3.* by chance?
Try with TWRP 3.2.3-0, it’s the most stable and trouble-free version.

Or really format everything. Wiping is not formatting.
For the data partition, there’s a “Format Data” button.
For Dalvik / ART cache, system and cache you have to select the partition in Advanced Wipe and then use “Repair or Change File System”.

1 Like

Yes, I used TWRP I didn’t know I had to do more than go to Advanced Wipe and select everything except Sim card. I thought that if I went to Advanced Wipe I could simply select “Internal Data” as well, so I could skip the “Format Data” step in this tutorial.
Was I really wrong thinking that? Why doesn’t the tutorial tell me to “Advanced Wipe” everything at once?


  1. Most of the times it is wrong to assume one would know better than any given tutorial.
    At first you cook strictly according to the recipe, experimenting with ingredients comes after you really understand the inner workings of the recipe :wink: .
  2. As I said … wiping is not formatting. Wiping just deletes any files and may leave the empty directory structure (I don’t know if it does that all the time, but I’ve seen that myself). Formatting really formats the partition.

Because wiping is not formatting.


Alrighty, thanks for explaining. I’ll wipe and format my phone properly tomorrow. XD

Okay, I did it and it finally worked. Note that

  1. if you want to use FP2 OS over lineage, you have to wipe and format and stuff before running the batch-script
  2. the new FP2 OS refuses to connect to my WiFi, so I had to try again with fp2-gms-19.05.3-manual.
  3. refused to connect to my WiFi as well. It just said “no internet”

So, now I have the older FP2 OS installed again, the freeze bug could be reproduced and this time I hope they’ll finally accept that they have to take it back.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.