Installing Fairphone OS Manually not working

Hi!

I’m having problems flashing a FP3 with Fairphone OS. Before it was on latest LinegaeOS. I’m running Debian 12.1 (bookworm).
I downloaded FP3-6.A.023.1-gms-497e9bef-user-fastbootimage.zip, decompressed the file and lunched flash_fp3.sh
Looked nice at the beginning, but then it got stuck with the following line:

Sending sparse 'vendor_a' 1/2 (458740 KB)...

Everything before finished with OKAY.
I’ve tried it for two times now, without a change. Any idea?
Thank you!

Flashing via script takes a while. How long did you wait for this step ?

20mins maybe
I also tried an other USB cable.

I used the script one time and as far I remember ,it lasted longer that 20 min. Try it one more time over night and see, if it worked.

Ok. Thank you and have a nice evening!

Good morning. Unfortunately even the night brought no solution.
I have no more ideas. :thinking:
Does it make any sense to flash an other image in recovery mode? Or might that break something?
We own 3 FP3s and one FP4 all rooted and all with LineageOS. I never came across something like this…

https://xdaforums.com/t/unable-to-flash-stock-google-pixel-3-sending-sparse-vendor_a-1-2-262140-kb.3895156/

https://www.reddit.com/r/GrapheneOS/comments/cme2jj/flashing_failed_while_sending_sparse_vendor_b/?rdt=57584

1 Like

I used a short Anker USB-A to USB-C cable. Do not use “noname” USB cables. They often causes problems, you may not associate with the cable.

Edit
Another reason for “strange” behavior of the FP3 could be the bottom module (see here).

2 Likes

Thank you so much!
It finally worked. First I had an Anker USB-C → USB-C cable, then I changed to another port and the Fairphone Lifelog cable :wink: finally an Anker UCB-A → UCB-C cable was the solution.
I ended in a bootlop at first but I was able to solve that.
Have a nice weekende!

4 Likes