English

Installing directly from apk

Hi there,
since the update to 6.0 (which, apart from the following problem, works great for me), I’m not able to install apps directly from apk. “Install from unknown sources” is activated, but when I tap on the downloaded file (in this specific case, it’s the Amazon Underground app), it says “Datei kann nicht geöffnet werden” (File can’t be opened). I use the standard, non-rooted FP OS - on Lollipop there was no similar problem…
Any ideas? Thx!

Does it happen only with that apk? If so try re-downloading it. Maybe something went wrong with the download.
If it happens with more than one apk, do they all come from the same source? Is it trustworthy/e.g. official site of the App’s developers? If so try downloading any app from a safe source like F-Droid, to see if it’s an issue with the source.

Same Problem with the F-Droid apk…

Hm strange. Where do you save the files? External SD card maybe? And which browser do you use to download them? Did you give the browser all necessary permissions? Does it also not work if you Go to Settings > Storage and use the file browser to navigate to the file?

Well… I downloaded with Chrome, the files are in the “Download” folder of the internal Storage. And it doesn’t work either if I navigate directly with the built-in file browser…

That’s really odd. Unfortunately I’m out of ideas. :confused:

I tried and installed another file manager (fx) and it worked to install the apk’s from there! No idea, why the built-in manager didn’t do it - but it’s solved anyway now!

3 Likes