Install rom stock fairphone 4 after install /e/os

Hi all,

I would like to know to now how to install th rom stock for fairphone4 after i install /e/os.
i follow [https://support.fairphone.com/hc/en-us/articles/4433978210833],but i have an error message as:

so i am a little bit lost.

thanks fo your help

Hi and welcome, whatever you do dont lock the bootloader afterwards. It would very likely brick your phone.

Some information here

2 Likes

thanks,but i am not stuck in a bootloader loop,i install again /e/os and its works,but i want to install Ubuntu toucth and for that i need to install first the rom stock on my F4

Cant help with this, just wanted to warn you. Have you tried again?

thanks for the advice,yes and same issue,apparently the partition frp are missing,is it due to /e/ os? and how to repare it?i look evevrywhere and found nothing

Did you unlock critical as well as decribed here?

yes i unlock all and didnt lock after juste in case

That looks like your fastboot is outdated, what’s the output of fastboot --version? :thinking:

fastboot version 33.0.2-8557947

Hmm, yeah, that’s not it then…

Could you check if you have frp_for_factory.img in the images folder?

yes i have it on the folder

i download this one FP4-FP40-factory.zip

That’s the right one :+1:

Ok, some other things to try:

  • Have you tried running the script as root
  • From the looks of it, you are running this in a WSL environment, right?
    • Have you tried the .bat version instead
    • Have you tried running it from a proper Linux live medium
  • If all of that fails, try different USB ports, fastboot can be very particular in that regard
1 Like

honnestly,i try it on my windows laptop,ubuntu laptop,with different cable and time
i start to pissed of

do you know the command in ADB to get all the varaible on the phone? i forgot it?

a new one

That means you didn’t unlock critical partitions, you’ll have to run fastboot flashing unlock_critical, beware that this will wipe your data (which you probably don’t care about anyway :smirk:)

2 Likes

let me try just in case,no the phone are empty

What do you mean by that? :thinking:

I don’t really understand why you suddenly can’t flash critical partitons anymore, when, according to your previous screenshot, you just did.
Did you use any commands in between?

My advice would be, move this over to your Ubuntu laptop, so we can rule out Windows doing something weird.