Install /e/ on a Fairphone FP4 - “FP4” (beta)

I guess because ADB and fastboot get distributed together they often get lumped together as simply ADB.
When we get into detail, the two are seperate entities working with different modes of the phone, and referring to fastboot as ADB then leads to confusion in troubleshooting.

I think we should assume fastboot doesn’t find the device.

Thanks for all the answers. I managed to install /e/ using my old Win7 pc with a usb-cable I bought with the FP4.


Waiting for any device,… unauthorized,… I also had the messages/ errors and was also stuck in fastboot mode. Just wanted to “try” to explain how I solved it.
Good luck :slightly_smiling_face: seems to be more difficult to solve because we need a way to enable “oem unlocking” without a working OS/recovery

Es ist ja bereits bekannt dass einige Apps nicht laufen. Osmand, Aegis, etc… Das ist auf die geringe jvm heapsize zurück zu führen.
Ein issue ist in Git eingekippt, bekannt und bereits gelöst. Kommt mit dem nächsten Update.

Workaround für die, die nicht zum Update warten können: im /e/ Forum eben berichtet und von mir bereits getestet. Funktioniert. Danach läuft Osmand, davor nicht.


Thanks @AlphaElwedritsch that finally explains the Magisk issue we were investigating


Test Option: *#*#2886#*#* is no longer working wih /e/
Is there an alternativ, or is it not possible on /e/ (Lineage, CustomRom) in general?

It’s the same at least with the respective test menu dial code for the Fairphone 3/3+ in /e/OS. I wouldn’t get my hopes up.

Maybe @urs_lesse found at least a solution for some the tests. The Fairphone Checkup App (Originally for the FP2) fork available on F-Droid seem to work on other phones as well

1 Like

In vanilla FPOS it’s called MMITest. It should show up under Settings → Apps if Show System is active (or check it with adb shell pm list packages mmi).

If it’s there you can trigger it with

$ adb shell am start-activity -n

Edit: I checked the /e/ images, it’s not included.

I had same problem. I tried with diffferent cables, with no luck. I also try to force reinstall of the driver from the devices manager. No luck either.
I finally solved the problem with a simple “windows update”. But I had to go in “the optionnal updates” part. There I found updates waiting for Android.


1 Like

Yep, that’s the most frequent issue on Windows
You have to install ADB & fastboot drivers in the Windows Update section “Optional updates”
I remember they detailed the procedure for FP3 afaik, but nothing for the FP4

That’s it with W11, if it can help someone:

:warning: For the last one, you can check only the ones that are related with ADB (Android Debug Bridge) and fastboot :warning:
However, I advise you to do all the updates, these are frequently drivers updates

1 Like

Also, I have found quite a few bugs on /e/OS:

  • All the given apps that are not up-to-date (that’s a /e/OS classic, but fortunately we can have them on F-droid, and uninstall the stock ones with root and Package Manager)
  • Discord is crashing VERY often, but still usable if you have the courage to force-close it every 5-10 minutes x) - No solution found
  • Aegis is literally not working, after the setup it crashes, and when re-opened it restarts the setup, and re-crash…
    An alternative solution is andOTP (with no biometrics support :confused:), but you have to:
    • export your 2FA codes in a plain text file (not Aegis .json file) before going to /e/OS (not very secure)
    • or have Aegis (and your 2FA codes) on another device and just scan all the QR codes with andOTP on your /e/OS FP4
      (for any help, feel free to ask me :wink:)

Apart that, everything seems to work well for me, with Lawnchair 2 (got it from Aurora store, cause the stock launcher is horrible) and Magisk root (I’ll make a wiki on how to do it in a few days :wink:)


That’s probably due to a known bug of not enough allocated memory (maybe the same for Discord):

AFAIK it’ll be fixed in the next update.


Cannot confirm all these issues in iode…
But yes, you’re right, had the same problems before on my FP4 with /e/OS

I’ll add that the workaround from that link has fixed the issue with Discord (and Newpipe, for what it’s worth) crashing for me.


Do you know if Aegis is working on iodé ?

Yes it is. There’ s enough memory
Thy didn’t do the mistake like the /e/OS guys with the jvm heapsize

I’ve got everything in place now, but got stuck with the backup options. Found this thread stating that TWRP misses user data and this wiki and now I’m confused and would appreciate a hint into the right direction.
I can live with backing up my files manually, but would like to back up system settings and app settings to recover my FP4 to the state it is right now.
Is adb the way to go?

@Alex.A Is the wiki only for FP2 or also FP3? As its the second time someone stumbles over it, we should maybe add that its not for FP4, because

@OvO I think in the above its already clarified at least that the wiki doe not work and data can def not be backed up using TWRP

Edit: @OvO reg ADB backup you might want to read this thread