Increase number of volume steps?

First, I am super happy with my FP3. When hopefully soon a G00gle-free OS will be available, it will be perfect. Just one thing is bothering me a little: The amount of volume steps. When I connect e.g. my bluetooth speaker and set the volume to a certain point, it is very quiet. It’s ok, but the volume is really low. Then I increase the volume just by one step and the volume is screaming loud. Something in between would be helpful. Any ideas what I could do (no root)?


How do you increase the volume - using the hardware buttons? Those settings are really a bit coarse. Have you tried the more detailed mixer that you can call via the gear icon?

Thanks for the hint, I just checked it out. Unfortunately it seems that for me these settings behave the same way like the hardware buttons I am normally using. Interesting though that it seems to be different for you. :roll_eyes:

Sorry, you’re right: the mixer has the same steps for setting the media volume. I just read some (German) forum posts about this topic. Result: you are going to need a third-party app for this. There seem to be plenty in the Play Store.


Hmm, the thing is, I’m not using any tracker infected stuff from Google Playstore (means I am not using it at all :slight_smile:) and on F-Droid I haven’t found anything working unfortunately. Will continue to look for an App.

1 Like

If you feel to, the number of steps can probably be increased somewhere in /vendor/etc/mixer*. You need a rooted device.


Yeah, I read about that and I was thinking about rooting the FP3 for other reasons as well, guess I will try it after having found out how to do so. :face_with_hand_over_mouth:

:partying_face: I found a real quick fix at, that worked like a charme for me here. You do not need a rooted device and you do not need to install any app (there are some apps out there for volume control and none of those did the trick for me).
Basically the fix is to control your FP3 media volume and your bluetooth speaker/headphones volume seperately:

You have to enable developer options and there you have setting called “Disable absolute volume”. Enable this option, restart your bluetooth device as well as bt in your phone and voilà! You can now use Adapt sound and change the volume of your devices separately.

Step-by-step on your FP3:

  1. Go to your device settings, scroll down to “About the device”.
  2. Again scroll down and touch at “Build-Number” repeatedly.
  3. You’ll probably be asked to enter your pin again.
  4. Go back to your device settings.
  5. Go to “system”, “advanced”, “developertools”.
  6. Then scroll down or search for “Disable Absolute Volume Control” and enable it.
  7. Turn off your speaker/headphones. restart your FP3 bluetooth. Turn on your speaker/headphones.

Now you can set your FP3 media volume to a suitable value and fine tune the volume with your bluetooth device’s volume control.

I hope, this is helpful to some of you!


Thank you for a solid working answer. :+1:

Hi and welcome to the forum :slight_smile: are you referring to the above post by @Amsoht, just to be sure.

There are a number of posts on this issue.

Lovely guide! Thank your very much :)))

Thanks! Worked to “disable absolute volume” in developer options.


Thanks to all, but with my FP2 with newest FP OS with A9 i can do as @Amsoht tell, but when i disable developtertool (should be for normal use) the button disable switch back to unable. I did not find a way to stop this. Any help?

Actually it’s the same thing with my Fairphone 3. I decided to live with developer options being enabled :man_shrugging:

Where’s the harm in having developer options enabled? It’s just a bunch of additional options, not a special mode the phone would be in or something.

If you changed a useful setting in the developer options, just leave them enabled.


Same problem here. If you listen very carefully, you’ll notice that there should be one step in-between that “too low” and “too loud” setting. The volume seems to increase twice for only that one low level. I never found a disuccion on the web discussing that same behaviour.
I cannot currently restart my phone to test your solution due to the issues with android 13 and the fingerprint sensor. Just enabling the option, disabling Bluetooth, reenabling it and reconnecting to the Bluetooth speaker didn’t help me.