In which folder should an image go to be "detected" by the text message app?

I’ve copied an image to my fairphone4 with scp, but when I try to send it via text message, the text messaging app doesn’t seem to be able to detect it. I’ve tried putting it in a variety of folders, like ~/storage/pictures, ~/storage/downloads, and /storage/emulated/0/Pictures. The “Files” app can’t see it either, even though I can see it on the terminal with a terminal app. Does anyone know what’s going on?

Are you sure you didnt put the picture under the filder of the terminal app? Tried testing it with a different picture? (connect the phone to a pc and put the ic manualy into the download folder or just download a stock img)

Where did this image originate? I don’t know what you mean by “scp”, but

  • if the image was on a PC or Mac, just use a USB cable, and make sure on the phone to enable file transfer for the USB connection ;
  • otherwise use Bluetooth transfer.

No terminal app is necessary or recommended.

The choice of folder is not really important, as long as you avoid areas normally reserved for particular operations. I would put the image in (maybe a subfolder of) Documents (internal storage).

In proper terms (SMS), you can’t. But you can use the stock Messages app (and alternative message apps) to send a MMS with attached image, as long as your network operator provides the service.


  • Using the Files app, select (long press) the file(s) you want to send.
  • Choose the “Share” function (three joined dots) at top of screen.
  • Choose the Messages app. This will open a new message with the selected file(s) attached.
  • Indicate the destination mobile number (or contact name)
  • Add any text you want to the message.
  • You will see that the “Send” button doesn’t say “SMS” but “MMS”. Tap to send.

Maybe, but ~/storage looks to be in the home folder, while /storage looks like a system folder. But, I’m starting to suspect that one might be an alias of the other.

OldRoutrard, scp is a terminal-based file transfer program. In this case, the image is coming from a remote linux server, so I don’t have physical access. I use scp and the terminal a lot of other computers, and it would be great to make this work here.

Indeed, this would be via an MMS message, which my operator does support.

The Files app seems to be having the same problem as the message app, it can’t see this file, even if I put it in the folders I described above, like ~/storage/pictures.

OK I understand the problem a bit better!

Then I guess you might be running into problems specific to Android (which let’s remember is not Linux), in particular write permissions. Unless the Android device is rooted, you may not be able to write anywhere except the specific user data directory of the app you’re using.

So I’d advise checking out a bit more on pulling files to an Android device over scp.

I’m not sure what happened, but the image is now detected in the message app multiple times, as if the app became “aware” of several (all?) of the instances. I just tried to replicate this with a second image, and the message app doesn’t see the new one, even after I closed and opened the app. Interestingly, the “files” app does see it, although it only seems to see one instance.

Does anyone know how the message app works with regard to images? When I move to attach a picture, it shows me a set of pictures available, but not any information about where they’re located. It’s not like file selector.

Or, maybe, here’s a better question: If every app has its own data directory, then what’s the path for the message app’s directory? OldRoutard, that would let me test the idea that I can’t directly write to it, although perhaps we’ll get lucky.

Can you confirm that you opened a chat and after clicking on attching picture you selected folder

And after tha the following is seen and you clicked on the 3 dots to open more folder/options?

1 Like

yvmuell, my message application looks different than yours. I wonder if we’re using the same app?

But, you comment did partly clear something up: When I try to attach a photo, the message app gave me what I thought was just a list of all the photos available, but actually it was a list of folders, with one photo (the first?) in each folder acting as an icon. So, it seems like the message app is aware of the other folders that I’ve been trying to use. And, when I opened those folders, the images I was testing with before were there! So, that bit was my mistake, thanks!

However, I was about to mark this thread as “solved”, but as a final test I just tried to transfer another image. The “Files” app sees it, and I can see it in the terminal, but the message app doesn’t detect it. I definitely have the right folder too, since when I delete another image from the same folder in the terminal, it immediately disappears from the message app. So, even though the message app is aware of the folder I’m operating it, it doesn’t (at least immediately) become aware of new images that are put there.

Maybe there’s someway to trigger a refresh?

Restarted the message app?

1 Like

Well I never transfer pictures to my phone to send them via messages app, so no idea how that would work. did you wait a few minutes after the transfer while the messagws app was closed before you tried to send it?