Impossible Hard reset


My fairphone really has big problems, especially with the fact that it does not recognise its battery and I have to send it back for repair. My new problem now is that I would like to send it back with no data on it but I cannot erase it! when I go to settings and click on factory reset, my phone just switches off and nothing happens. I also tried to do a hard reset with the start and volume up bottom but again, nothing appears, no robot, no menu, nothing. I am getting quite desperate with this phone and all of its problems. What could I do to erase all of my data to send it back for repair? I don’t want to send it back with all my contacts, pictures etc etc… :frowning:

Do you know someone near you with a working FP2?
Maybe you could try their Battery and/or Bottom Module in your Phone to make it work long enough to do a Hard Reset (Factory Reset only resets your Settings).

If you don’t know anyone you could try one of the #localcommunities near you.

Factory reset formats the data partition which does indeed erase all user data.

@Sellebride, if this is related to your battery issues: Did you try it while connected to a charger?

1 Like


Sorry I did not explain the whole story but my phone does not recognise my battery. The phone is only 5 months old. I already went to a shop that sells Fairphones to see if it was a battery problem. we put my battery in a brand new phone and it worked perfectly. we also put a brand new battery in my phone and it did not work. so it appears that my phone is the problem. some connectors are probably not working anymore. The only way to get it started is to plug in my phone, remove the battery until I hear a little vibration and then put the battery back and then it starts normally. As soon as you unplugg the phone, it dies. If it is not plugged in, there is no way to turn it on. it stays totally black and the start button does not work. That is why I contacted the company to send it for repair and I recieved all the documents but now that I want to send it, I cannot do a factory reset… I don’t know what I could do, and nobody seems to have had this same problem …I don’t really want to send it with all my data on it, although I have nothing to hide, but you never know!

Press volume UP while powering on or rebooting, this will bring you to the Recovery, from where you will be able to wipe user data.

Have you tried keeping Volume Up pressed the entire time while performing this procedure?

You could try to use ADB to reboot into your recovery (the command is: adb reboot recovery).
Or, you could also wipe your data partition with fastboot.

Thanks for all of our suggestions. Pressing the volume up button while starting the phone actually worked this time but when I select the factory reset, it first seems to work and then tells me it can’t be done… I don’t understand why… haha I think I’ll just have to send it back like that!

Thats right! You can send it back for repair or you could try to disassemble and reassemble it and begging every single contact-pin to work properly :wink: If the latter does not work, the first will do it …

A post was split to a new topic: Can’t get to Android 6 recovery