I have several invisible and inaccessible apps 'installed'

I had a problem with Google Play crashing. I upgraded my Fairphone to Cherry, and upgraded Android to 4.2.2. I did a factory reset to try and clear out everything. This latter move was not successful. I cannot install Google Play Store or the google Play Installer app. If I use a computer to go online to install some of the apps that I had previously installed I am informed that they have already been installed. However I cannot find them anywhere on my telephone, hence I cannot uninstall them or use them. I would appreciate some help with this problem.

Maybe only config files are still now in the phone. Try to find the android database folder with a file browser and delete configs for apps that have problems.
It’s strange that factory reset left these files, but I have no other idea.

Or go to ‘apps’ and delete there the apps that have problems. Normally you first make a backup, but I think you already did so before the factory reset.

I can’t go to apps and delete them because they don’t appear anywhere.

Why can’t you install the google play store? Have you added a shortcut to the widget onto your home screen and attempted to install? If so does it give an error etc

When on google play online, it may show apps that are ‘installed’ but you can click the green button that says installed and it will bring up the install prompt as usual with the permissions screen. Simply press install from there again.

If I connect to the google play store on my Fairphone there is no option to install the play store. I can see a list of apps that are allegedly available for installation. If I select one of them, for instance BBC news app, and click on the Install button I get a message saying that the app will be installed soon. A short while later the screen displays ‘Installed’. However I cannot see the app anywhere on the telephone. I have managed to successfully install some apps from F-Droid. I can see and use those, the problem seems to relate specifically to Google Play Store. This whole thing started when I began to get a message when I first switched on my telephone in the mornings saying that Google Play had stopped working.

I have the same, very unpleasant, problem! And I cannot solve the problem.
For instance, I cannot use Swiftkey as alternative keyboard :frowning:
What are we doing wrong?

1 Like

@Trevor_Lewis & @Stiller When you go to Settings > Apps do you see an entry called Google Play Store? If so, tap it and search for a button called Launch (or Ausführen in German).

Does this start the Google Play store and makes it work?

This, I guess, is the root of your problem and what needs to be solved. Could you be a bit more specific - why can’t you reinstall Play Store after upgrading? What are the symptoms, or error messages? Have you checked the following guides:

It seems that @Trevor_Lewis did manage to install the Play Store, is that right?

I did succeed in restoring Google Play Store. However, I prefer a strictly limited use by Google of my phone. So I downloaded an alternative GPS app (OsmAnd~). But it turnes out that a program like ObsMapp and also Reisplanner (of the Dutch railways) will not run without certain Google apps.
But still, now everything is reinstalled (and both mentioned apps are running again), I still get the notice ‘will be installed later’ (zal binnenkort worden geinstalleerd), when downloading and installing two apps: Th@s Invasive! and also Swiftkey.
Can it be, that Google is blocking both, because I do NOT want a Google account?

Could be, but when reading what @Trevor_Lewis wrote later - “If I connect to the google play store on my Fairphone there is no option to install the play store” - I began to wonder if he meant that he visited the webpage play.google.com

I believe I have now managed to solve my problem. I did a system restore of the Fairphone OS, by downloading the zip to an SD card inside the telephone. I followed the instructions in this article: https://fairphone.zendesk.com/hc/en-us/articles/201189497-Fairphone-OS-multiple-versions-.
That allowed me to use the Widget ‘Google Apps Installer’ to reinstall the standard Google apps. When I opened the Google Play app I was able to install the apps that I had installed previously but then went missing.

I am such a happy bunny!

Thanks for your responses to my original pleas for help.

2 Likes

Excellent. Glad you got this sorted in the end

This topic is now closed. New replies are no longer allowed.