I can still access Internet even when all Internet sources are disabled (Wi-Fi, mobile data...)

Hello everyone,

I noticed something strange with my FP3 running the Fairphone OS build 6.A.018.0 (first version of Android 13 on FP3).

I disabled all Internet sources (Wi-Fi, mobile data) but somehow the phone still gets access to Internet : speedtests, watching YouTube etc still work like if the phone was connected.

I disabled the option “Mobile Data Always Active” from dev settings (I don’t think I activated it in the first place). Rebooted. Still the same behavior.

Any clue ?
This behavior doesn’t appear to be normal.


1 Like

How do disable? Flightmode, Internet quick menu tiles, settings?

Did you configure bluetooth as wifi? Is bluetooth off?

How would one do this?

That is for a Pixel Phone, I guess it would be similar to FP.

Ah ok BT tethering… However thats to share from FP to another device normally? So how do you think will this provide internet to the FP itself?

If there is a second mobile phone or a tablet with mobile connection.

That has set up BT Tethering enabled and can auto connect with the FP, yes than its possible a connection without authorization would be more than odd…

@yvmuell @Jens1

I disable Internet sources using the Internet quick menu tiles (which actually stays highlighted). Doing so, I can still access Internet.

If in airplane mode, no Internet connexion anymore (and Internet quick menu tile is greyed out)

For the sake of trying, I disabled airplane, disabled mobile data, wi-fi, bluetooth. Still able to access Internet.

Did you try a website you have never visited before with your mobile phone?

1 Like

Did you check in the network settings after disabling in the quick menu? Maybe there is a bug with the quick menu.

I was able to reach unvisited websites with Wi-Fi & mobile data all disabled

A few screenshots of all sources disabled (without airplane mode)
With that state, I could reach websites I never visited before

1 Like

Do you have a second SIM set up that could provide internet?

1 Like

Thats weird as there is even the exclamation mark, which normally means no mobile data…

Can you test another SIM from a different provider?

Although I find this unlikely did you check with BT also disabled, as suggested above?

And finally, is mobile data disabled here as well

only one SIM card in the FP3

Released back in July.
I strongly recommend that you update to the latest version available, currently 6.A.022.1 released 31 October.
If you contact Support they will likely ask you to do that. Is there any special reason why you haven’t yet done the update?

I note in passing, that the intermediate 6.A.020.0 update released in early September, included a patch to correct a " bug that was causing hotspot/tethering to not work in some situations". Maybe that patch also fixed the problem you are seeing. At any rate, some networking code was patched.


Hello all,

First, thanks a lot for your different advises.

I tried to use another SIM card from another network provider (Sosh) following @yvmuell and @alextdrw
On this other provider, turning off Wi-Fi and mobile data from the tile, it is not possible to access Internet, so the phone behaves as expected.

Following @OldRoutard suggestion to use the latest version (6.A.022.1) instead of first Android 13 version (6.A.018.0) :

Using Bouygues network, I was proposed to upgrade to Android 13 (6.A.018.0) on 2023-07-11, which I did. However since then (> 4 months), I was never proposed to update to next releases 6.A.020.0 or 6.A.022.1).
I regularly checked if system updates were available in the dedicated menu, without success.

Using Sosh’s SIM, I was directly proposed to update to 6.A.020.0. Once done, I was proposed to update to latest release 6.A.022.1.
So now my phone runs the latest release. :smiley:

Using 6.A.022.1 I again tested the use-case:

  • behaves OK with Sosh SIM
  • still behaves NOK with Bouygues SIM


So its somehow connected to the provider and I would inform FP as well as provider support and ask them to fix this.

1 Like