How to turn off the "no wifi" alert

Since I updated to Android 7, my Fairphone 2 keeps alerting me with a sound whenever it loses my home wifi signal (which is often, and I dont know why since the signal is good) It always comes back within a minute - or I simply reconnect to my home wifi but the sound alert is most annoying - is there a way to turn it off? (Assuming there is no way to stop it disconnecting from my wifi several times a day)?

I don’t know about such a notification when disconnecting from a Wi-Fi network. So I assume a third-party app is responsible for that. (I might be wrong as I muted and disabled sound notifications completely.)

Is a notification card shown when the Wi-Fi is disconnected? If so, you can long press the notification card to reveal which app is responsible for that notification. Then, you can look into the settings of that app if there is a way to disable that notification. If not, you can block notifications from that app by long pressing on a notification from it. Alternatively, feel free to uninstall that app.

Edit: I have turned notification volume to maximum and went away from home. No sound appears.

1 Like

Perhaps it’s worth a try.
Could it be that you hear a notification not because it disconnecting from a Wi-Fi network, but because the phone has found a public network.
Go to Settings
Go to Wi-Fi
Tap on the icon afbeelding on the right on top of your screen.
If the ‘network notification’ is on, switch it off. And see if this makes any difference.
What is the setting at ‘Keep Wi-Fi on during sleep’? I have it on ‘always’.


It’s exactly that- it was telling me a public network was available ( presumably in the short interval it lost connection with my home wifi) Thanks- I’ve disabled that settkng,!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.