How to turn off autocorrect in text messaging?

Sorry if this is a silly question - but I can’t seem to find any way to turn off autocorrect/word prediction in the default text messaging app on my new Fairphone 2. It isn’t in either “Help” or “Settings”. Are there some global settings for the on-screen keyboard that I’m not finding or something?

Slightly related, it’s a bit annoying that both the default text message app and the Facebook Messenger app are called “Messenger”. Is there a way to change the app names on the screen so that the former is called “Text” or “SMS” or something?

I think, autocorrection of words is set straight in the keyboard app.


Go to “Settings”

  • Language & Input
    • Spell Checker (on/off)

I guess, that’s the neccessary setting.
I turned it “off” as well.

@AnotherElk @Amber was correct; it’s to be set under keyboard-settings.

  • Language & Input
    • Keyboard & input methods - Android Keyboard (AOSP)
      • Text correction

That’s where you get quite a few options and can turn of “Auto-correction” etc.


Thanks all, I have sorted it now :slight_smile:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.