How to start using Google Now?

I just installed the Google Now Launcher. It says that Fairphone OS is the default app, that I need to Clear Defaults, and click the home key. But when I do that, nothing has changed. Going back to the menu and starting Google Now Launcher again, it says the same.
How can I start Google Now Launcher?

Did you actually clear defaults?
If not, go to Settings > Apps > Fairphone OS, scroll down and press “Clear defaults”.

1 Like

Yes, I actually did.

Did you restart the phone after installing Google Now Launcher?

Yes, I have tried turning my phone off and on again.
I have also tried uninstalling and installing Google Now Launcher again.
I have also tried stopping Fairphone OS, removing its data and clearing its cache.

None of which helped, unfortunately.

Normally, when using the home button after install, you should be asked which launcher you would like to use. I installed the Google Now Launcher myself to see what happens:

After Install, i started the launcher by clicking its icon, i got the same message you did. I tapped settings and scrolled down until i saw “LAUNCH BE DEFAULT”, i tapped “Clear defaults” directly below, afterwards, the text below change to “no defaults set”.

Now when i tap the home button, i get a dialog to choose a launcher. I tapped “Google Now …” and then “Always”. Immediately the Google Now Launcher appeared and sill does when i press the home button.

To summarize: There is NO RESTART and NO CLEARING of CACHE or ANY DATA required.

Here are some screenshots to help you find the right buttons:

Edit: For some reason, disabling Google Now Launcher is not possible this way, the button was greyed out. I simply uninstalled the Google Now Launcher via Settings-> Apps and could choose a launcher again at the button press.

1 Like

I know what it is supposed to do. The steps you describe are the same as described in the small dialog where it says to Clear Defaults. Also, under the title “LAUNCH BY DEFAULT”, it says “No defaults set.”.

My problem is: the dialog “Complete action using” is not shown when pressing the Home button (which is, I assume, the middle button beneath the phone’s screen).

But still, when I try to start Google Now Launcher from the apps menu, it says “Fairphone OS is currently your default launcher.”.

A similar dialog does show up when I clear the defaults for, for example, my browser, and then click a link from another app (then I can choose between Chrome and the standard browser, in the same way you can choose between Fairphone OS and Google Now Launcher).

These are the reasons why I tried clearing data/cache and forcing to stop Fairphone OS. (I told so in order to prevent trouble-shooting like “try this, now try this, now try this” but that didn’t seem to help.)

If any screenshots are needed, I’d be happy to provide them.

@Lewistrick Could you try installing another Launcher, for Example “Launcher3” available on F-Droid or Nova Launcher?

When i did first install another launcher, the “complete action…” dialog appeared when pressing home (which is indeed the middle button).

And just to make sure (sorry) you are clearing defaults of the Fairphone OS launcher?

I installed Nova Launcher. Right after installing and going back to the home screen, Nova Launcher started without me having to select a default OS. (My guess is that the phone didn’t need to ask me so, because there was no default set.)

I went to the menu and tried to open Google Now Launcher. At this point, something very interesting happened. It showed me the “Complete action using” dialog, but it only showed Fairpone OS and Nova Launcher - but not Google Now Launcher, even though I tried to execute that exactly.

This really surprised me. Does my phone not recognize Google Now Launcher as an OS?
I also have a widget of Google Now on one of my homescreens. Is Google Now Launcher something else?
Also, my phone often tells me “Unfortunately, Google Search has stopped” or “Unfortunately, Google Calender has stopped” lately. I can’t really see where all of this is going wrong. I’m starting to think it doesn’t have anything to do with Fairphone OS.

EDIT: I found this topic somewhere else: and I’m going to try that later today.

Indeed it is! It is a separate app from Google (Now). But this is what you installed from Play Store after all, or not?

The crashes might have to do with clearing app data / caches. But they should not persist. Let me ask you, where did you download Google Now Launcher from? It is available in the Play Store and this should be your only choice. Do not manually install any zips or downloaded APKs for Google Apps unless you really know what your are doing. In that sense, the solutions provided in your link to no make sense to me. If you install such APKs that could be a reason for your crashes of Google Apps.

Yes, I only download apps from the Play Store (and one from HockeyApp - but I know I can trust that one). I have not tried the solution I posted.
And I did indeed remember downloading Google Now from the Play Store, however I couldn’t find it there - I can find it in the Apps Settings though.
Now I installed Nova Launcher, I can work with that one too, partly because it also supports “Ok Google” + command. It sometimes starts Fairphone OS instead, but I made a shortcut to Nova Launcher. I’ll use this as a workaround.

Anyway, thanks for all your help!