How to set own music as ringtone on a FP2?

I can’t seem to find a way to set my own music file as ringtone.
The settings only allow me to select a file from a predefined list of ringtones. So I figured that if I could not search for a file from the settings, I would add my file in the ringtone file.
Using Amaze, I did copy the piece I want to use in the folder /storage/emulated/0/Ringtones
But that file is now the only file sitting in the ringtone folder, so I did a search to find if there was any other folder with ringtones. I could not find any.
I tried to search for a file with the name f the predefined ringtone, and drew a blank again.
So still don’t know where ringtones are located, nor how to add one :frowning:
Thanks for your help!

It’s storage/sdcard0/Ringtones
Works perfectly.

1 Like

I strongly recommend Rings Extended. It let’s you easily choose ringtones independent from it’s file path.

Just another hint: don’t save your ringtones on your external SD card, this will lead to problems when removing the card or connecting your FP to the pc. You should always keep it on the internal memory.

1 Like

Well… the file is also in that folder,
and no… it does not work.
I can play the file from that folder, but I can still only find the pre-defined list of ringtones in the settings…

That’s really strange! It doesn’t appear in the alphabetically sortet list? Maybe it’s the file format… I use mp3. Or the file name? My files start with letters…

So indeed quite a few puzzles (for me at least)

  • after being added to the ringtone folder, the file does not appear in the alphabetically sorted list in the settings
  • in the ringtone folder, Amaze only shows me the file I copied there, while I was expecting to see all the ringtone files > are they hidden somehow?
  • the file name in the ringtone folder starts with a 02 (it is the second song in the album), but in my music player the name of the song is displayed correctly
  • when I copied my music files to the FP, all files were converted to the .wma format > fist action: convert it back to mp3

yeah, mp3’s are the best :slightly_smiling:

Also always try to keep filenaming as simple as possible.

In my folder, there is only my ringtone as well. If Your dong name starts with 02, it should be the first in the list. Did you scroll to the very top?

Von meinem Fairphone 2 gesendet.

Problem solved - Converting the file to mp3 did the trick: the song now appears in the list of ringtones in the settings
Thanks for your help :slightly_smiling:

1 Like

Is *.ogg also supported? I’d like to copy some of the ringtones of FP1 to the new model :slightly_smiling:

would it be the same as setting a song as a text notification on Fairphone 1? which is very faffy.
1/ file manager
2/ internal storage
3/ my favourite (or keep trying files till you find your download)
4/ highlight and copy your song
5/ back to internal storage
6/ paste song into notifications
7/ open texts
8/ settings
9/ notifications
10/ ringtone
11/ chose song
12/ OK then close

Hey… i said it was faffy. if there’s an easier way i’m ready and waiting folks


At the end I have done this:

  • Connect your phone to your computer.
  • Go to “internal storage”.
  • Folder “Ringstones” for melody
  • Folder “Notifications” for other notifications: email, whatsapp, …

This topic was automatically closed after 3 days. New replies are no longer allowed.