How to send caller id

Hi, I would like to know how to turn on sending my caller ID, so that if I make calls people see my number. I could not find the setting in my new FP3.
Thanks, David

Don’t have an FP3, but Android used to default to:
Phone App > Three dot button in search bar > Settings > Calling Accounts > [Relevant SIM] > Additional Settings > Caller ID.
As far as I know, what this actually does is change preferences with your provider, so you can also try to change the preference directly with them, or, for many providers, by ‘calling’ *31# to enable outgoing caller ID (#31# to disable) if the option is still missing in the menus.

Added: As pointed out below, it seems some carriers use different codes. See also my next post.
The location of the settings in the menu may be slightly different, see for example the next post.


Thanks Johannes, that helped me find it here: Phone App > Three dot button in search bar > Settings > Calling Accounts > [Relevant SIM] > GMS Call Settings > Additional Settings > Caller ID.


I had the same issue and in general this can also be solved by dialing the code *31# to activate caller ID transmission, and #31# to suppress it.

However, in my case, the opposite worked out! I entered the activation code *31# several times and it did not change anything. When I entered #31# it suddenly worked. Maybe a provider issue (both are German Telekom) but I just wanted to add this just in case anyone else - like me - can not find the option or wants to change this like real quick :wink: I think, this option is pretty well hidden… :stuck_out_tongue: I could not find it by using the search bar and entering “caller ID”. I find that somewhat misleading.

I’m not aware of any carrier that has Caller ID off by default. That being said, it’s all in the official Android help.

On any newly set-up phone (10 of them) I ever inserted my SIM cards (plural) into transmission of caller ID was OFF by default. -> also: #germany

Which carrier do you use?

I found the setting in the phone app (thanks @David_Winkler!), but a fellow user (different network, different country) couldn’t change the setting; it was greyed out. the #31# also didn’t work. Note they are using two SIM cards at once. Does this have to do with using two SIM cards at once or is it something that can be forced by the provider?

Also, does blocking caller ID still leave it enabled for your contacts?

The option needs to be supported by the carrier. If the option is greyed out, the carrier or the SIM does not list it as a supported setting. Dual SIM shouldn’t matter, as the option is in the SIM-specific menu or is toggled by ‘calling’ a short code via the relevant SIM. I’d suggest to check the carrier’s website and/or contact their customer service.

As far as I know it doesn’t treat calls to contacts any differently (as it is a carrier setting, and the carrier doesn’t know which contacts are on the device). You could potentially work around this as some providers do have codes to override the caller ID setting for the next call only. In some cases this code (or often the ‘overall’ code to switch) can even be used as a prefix to the regular number, so you could potentially add this to your contact’s number - though this may or may not cause issues with international calling. The codes for this vary (even more) per country and provider. One example which may work on some networks would be #31#0031207884400 to call Fairphone customer support (+31207884400) without caller ID (or *31#0031207884400 with ID)whilst leaving the setting untouched for other calls - if your carrier supports it. I recommend testing this with a friend by calling them before using this to manage your privacy.

It seems my previous answer was not 100% accurate. Most European countries and carriers appear to use *31# and #31#, but there are notable exceptions including, but not limited to, a number of German carriers. Check with your carrier (or for your country if you cannot find anything specific for the carrier) to make sure.

1 Like

Deutsche Telekom has standard *31# according to their website.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.