How to reset screen lock pin

My FP1U became my backup phone some time ago, so I haven’t used it in at least a year, but now that I’ve tried to do so, I appear to have a different screen lock PIN to the one I’ve been using in my main phone recently. Can anyone please advise whether there’s a way to change the pin other than, presumably, doing a hard reset? Thanks

If both of these apply:

  • There’s a Google account installed on the phone
  • The phone has a data connection (wifi or cellular)

… then you should get the option to reset the pin via e-mail after you enter it incorrectly five (or so) times.
If, in addition to the points above, you also installed Google device manager, you can remote lock the device from you Google account. The remote lock function gives you an unlock code, which overrides the PIN.

More advanced methods:
If you happen to have usb debugging enabled on the device, there are a number of ways to remove the PIN altogether (never tried any, so cannot recommend any method). If you don’t have USB debugging enabled, installing CWM as recovery may enable it and/or allow you to back up your data (both only if your phone is not encrypted).

Thanks Johannes. I would have said both of those conditions applied, but I think there may be other requirements as well. I was hoping initially that there may be a further clarification that the Google account in question be signed in: I’d changed the Google password in the time I wasn’t using the FairPhone, so the account was not effectively installed whilst I couldn’t remember the PIN.

For me personally, I somehow remembered the pin code I’d used on my FP1U, so I’ve tested the theory above to no avail: I’m afraid the same behaviour (five times incorrect would mean a 30 second wait before another attempt, but there’s no apparent ‘escalation’ after that: six sets of five times over four minutes resulted in no change) was seen both before I signed in to the Google account and after I’d signed in & used both GMail & GDrive to confirm as much.

Just tried now, and you’re right - this route doesn’t seem to work anymore!
Well, luckily you remembered the PIN. Seems device manager is the only way to go (which isn’t set up by default), but I haven’t tested it.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.