How to Install Lineage OS on FP2 for dummies

If you have doubts, you can at any time ask questions at the community chatroom: :slight_smile:

Shouldn’t you first make sure TWRP is working, for which you first need to root the phone.
Or am I missing something?

1 Like

4 posts were split to a new topic: Installing Open GAPPS on Lineage OS

Is the download link for Lineage OS down?

EDIT: link is up again:


No, you don’t need to root the system for TWRP recovery to work, :slight_smile:

Again tnx for the comments! I tried to get everything to put it into a step-by-step procedure to be sure. Right now I’ve got FP OS Open 16.07.1 on my phone. I don’t have any personal information, like contacts, photos or apps I want to keep. My phone contains primarely the apps from the FP OS Open. That leads to the next questions:

1a. Do I need to backup in this case? I suppose that it’s not nessecary to backup for the apps which come along with FP OS Open, cause Lineage will provide for the most basic apps and if not I can download apps from F-Droid for example.

1b. If I don’t need to backup to keep personal information etc, do I still to backup to have an image of my current system to be able to go back?

1c. If I do need to backup, can I do this by using the system option ‘Make a backup and reset’ on OS Open?

1d. If 1c is ‘yes’ do I need to put the backup on my computer or can I put it on a sd-card in my phone?

1e. If I have to put the backup on my computer, do I have to download and install Android Studio on my computer first?

Further on I understood that, if I do need to backup, I need to root my phone to be able to make a backup with Titanium. When I don’t need to do a backup with Titanium, I am now confronted with the next question whether I actually have to root my phone to start into TWRP. I read in one of the comments that that is necesarry. That leads to my next questions…

2a. Do I acually need to root my phone to start into TWRP (I just read that that is not necessary…)?

2b. If I root my phone, I suppose I have to use the option ‘ ADB only’. Is that correct?

2c. How do I know if TWRP is working?

2d. What happens next? Do I have to write command lines myself, or can I just reset the phone and install the image of Lineage?

And my last questions for now ;-)…

  1. Do I need to download and install modem firmware?

  2. I am still missing something?

Thnx a lot! That’s it for now :wink:

No, Lineage OS can be used out of the box and anything you’ll need you can get from F-Droid. (F-Droid is not pre-installed, but a browser is ;))

No you can simply wipe data in TWRP and install Open OS or FP OS to go back.

If you wanted to do a backup you should do it with TWRP

Open OS comes rooted. You just have to enable it in Settings > Developer Options (which is visible after you tapped 10 times on the build number in Settings > About Phone).

TWRP doesn’t need root.

If you want to use Titanium Backup you’ll need to enable root for apps

If you boot to #dic:recoverymode and that recovery is TWRP, then it works. :wink:

Just wipe data in TWRP and install the Lineage OS zip file in TWRP.

I didn’t but some people say this fixes some dual SIM issues.

I don’t think so. :wink:

1 Like

This totally worked, very straight and simple. Thank you Paul!
Btw. I updated my modem drivers to those from FPOS 17.04.08 prior to installing Lineage OS as recommended in this thread Porting LineageOS to FP2.
For this purpose it contains a flashable zip file to be used with recovery. Very convenient I must say.


@paul tnx!

I just tried to do it, but unfortunately it failed. I got the message ‘Zip signature verification failed’. I don’t know what went wrong… :neutral_face:

if I tap on the button in the middle below the twrp menu I get to see the following:

E: unable to find partition size for '/misc’
E: unable to find partition size for '/bootselect’
Updating partition details…
Full SElinux support is present.
E: unable to set bootloader message.
MTP Enabled

Did I brick my phone or can I get back tot FS Open?


some more information:

I had ‘me.twrp.twrpapp-26.apk’ on my sd-card and the adviced ota_zip for lineage. Maybe I had to download another image? The other possible mistake is that I tried to do everything in TWRP v2.8.7.0?

First thing: don’t Panic! :grin:

You did the Wipe before, right?

In TWRP, do the following: go to “install”, select “”, uncheck “Zip file signature verification”. Than “swipe to confirm flash”.

If you want to install open GAPSS as well, repeat the last step (of course without the wipe…). You can download them here. Choose ARM/7.1/nano.

Than reboot.

And remember: don’t panic!:grinning:


It’s a better idea to do this with the latest TWRP-Version. You can flash it from the old TWRP version (Install -> Image). Then do what @Paule said. :wink:

1 Like

@Paule It worked!!! :grinning::slight_smile:

Unfortenatly the setup wizard after the connection with wifi is made… Just install lineage again?

1 Like

I don’t know what you mean? Does it crash?
You can always bypass the setup wizard by touching all four corners clockwise, beginning from the upper left (here is a quite old video about this, but should still work).

Yeah, looks like. I get the message ‘Setup Wizard keeps stopping’.

touching all four corners doesn’t work.

And, is it finally working?

@Paule @paulakreuzer @s99h @Stefan @s99h

Yes :smiley::smiley::smiley: It’s working!!!

I tried once again. Now without wifi connection. I didn’t have got my sd-card in the phone. One of the two must have been the trick.

Thanx a lot all!