How to install a font in FP1U for having Greek (or Hebrew) characters?

Hi all !
I’am the happy owner of a community FP1U. I’m using it as a pocket computer, with a Bluetooth keyboard.
Now I would like to install a font having Greek characters in Unicode in order to display texts like :
Ἐν ἀρχῇ ἦν ὁ λόγος, καὶ ὁ λόγος ἦν πρὸς τὸν θεόν, καὶ θεὸς ἦν ὁ λόγος. (Jn 1,1) in ebooks or with MarkupNotes app (my word processor app).
So :

  • Which font must I install ?
  • How Do I do it ?
    Thank in advance…

Maybe these fonts are installed when you add the Greek and Hebrew languages to the Google keyboard.
If not, you could install an app like


Fixed in Lollipop. FP1 currently only runs an old versions of Kitkat ;(

But maybe maybe copying the ttf files to /system/fonts will work.

Using an online editor in an up-to-date browser could work as well. But you might will also need the right input system if you also want to edit it (= do more than just copy and pasting quotes).

The FP1 browser is broken. Do not use it. Try chrome or firefox.

1 Like

I’m using the unofficial #kitkat version on my FP1 and Greek letters (with most diacritics) are displayed correctly (at least in the notebook, see screenshot).

So basically the FP1 with #kitkat is able to display Greek letters.

1 Like

Where am I now ?

  • I have loaded the whole roboto font family from on my computer.
    The hinted folder has several variants of the font and they seem to have polytonic Greek characters (tested on Ubuntu). The fonts are heavier than those on the phone.
  • I have put the whole font family on the SD card of my Fairphone.
  • I have tried to copy it in /system/fonts/ with Ghost Commander but it failed. I got a message saying that the directory was read only. I’m not sure I was rooted during this operation.

I will retry later.

Some questions :

  • Is it an other way to copy from SD card to /system/fonts/ ?
  • Is it a way to confirm i’m rooted.
  • I don’t know how to install a non official kitkat, a Lollipop. Is there a HowTo for dummies ?
    My version of Android is 4.2.2.


( Yes I have made a copy of the previous version on my computer. )

Having root is not enough to be able to write to /system/. You need to remount it as readable. This should be fairly easy to do if you have adb on your computer: adb remount should do the trick.

There might be other ways to achieve this.

Yes, there is. (at least for Linux and Mac)

Please keep in mind: Android 5.0 = Lollipop. I’m not sure in which version exactly, the bug report I found was pretty short.

For the FP1 there is only 4.x available. I don’t think it will ever be upgraded to 5.x.

I run 4.4.4. If I find the time (busy week here, starting now), I will try to copy the whole roboto font family on my phone and check if it displays:

Ἐν ἀρχῇ ἦν ὁ λόγος, καὶ ὁ λόγος ἦν πρὸς τὸν θεόν, καὶ θεὸς ἦν ὁ λόγος. (Jn 1,1)

in its browser correctly. This is the test case, right?

Update: It somehow breaks things on 4.4.4 (text in the browser is shown correclty, but the system fonts break …). I just used the roboto fonts that I had on my system here. I “fixed” it by just reinstalling 4.4.4 via sideload. Looks like it is a problem with how fonts are used/displayed in Android. The browser looks happy, see the pictures below.

I have not installed any extra font and the Greek letters display correctly in Firefox mobile:

This is about the Notebook app and eBook apps, isn’t it, @frvipofm?

Thanks for your efforts !

Yes, the test case is the bible verse above.
Hum, the full roboto font seems producing strange behaviors on your phone… Not sure the solution of having the full font is a good one if it makes trouble somewhere else.
How did you copy the fonts in /system/fonts/ ?

In the train I’m using my phone as a pocket computer and MarkupNotes as a word processor.
And i’m producing my own ebooks to store books in my FP.
So it is not enough for me to display text in firefox.

For those interested :
The files, between the phone and the computer are sync with ownCloud (with desktop ownCloud on the computer, and FolderSync on the phone)
I have written a little bash script and a template to convert my markdown files in opendocument format with pandoc. I’m using this script as a Nautilus action on Ubuntu.

As @Stefan pointed out, it seems to work with Firefox. The default browser and some versions of Chrome (mine) seem to be unable to render the text correctly without the help of another font. I’m not sure about the reasons and how “clever” Firefox deals with this.

If you copy and past the text from Firefox (working) into MarkupNotes, does it look correct to you?

I don’t use MarkupNotes and I do not have it installed. But if it looks right in text, maybe just the rendering engine (that creates HTML and shows it using the “markup” code) got a problem?

So your Markup Code (if the text is still intact) could work outside of Android 4.x and render elsewhere correctly, thanks to Unicode (or not). Could you test this?

  1. Copy the Text from where it is show correctly (like Firefox) into your MarkupNotes application.
  2. Does it look okay in the text (yes/no)
  3. Does it look okay in HTML? (yes/no)
  4. Copy the text created in step 1 elsewhere, does it look okay? If so, you could process the markup file outside your cell.

I’m currently trying to copy the sans-serif font Fira Sans onto my phone. The best “open” fonts for rendering Greek texts in my opinion are Gentium Plus and Galatia SIL. I’ve only used Gentium so far.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.