English

[HOW TO] Flash a custom ROM on FP3 with GSI

Did you try to wait after the reboot ? :slight_smile:

Like keeping it shut down?
After fastboot reboot it directly goes into the rebooting cycle, which I ended after 3 mins or so…

EDIT: so I flashed the device again ( :slight_smile: ) and waited after reboot. That’s what happens:

  1. Software can’t be checked for corruption… boot in 5s –> I press power or wait
  2. Device is corrupt, power off in 30s –> I presss the power button
  3. Fairphone logo appears (b/w), device reboots.

Where should I wait? :slight_smile:

EDIT2: I can’t mount system on that slot in TWRP (Failed to mount '/system_root' (invalid arguemnt) hmmm, what does it mean?

1 Like

First, start from a clean rom with this script twice.
Then, to get rid of ‘Device is corrupt’, you should do adb reboot "dm-verity enforcing" in TWRP.
Finally, try again. It will reboot, you just have to wait (it have to work :wink: )

Thanks I will try. But I think there is something wrong with the script. (edit: there was, check it out now) At least the conditions when files get checked are flipped somehow. I opened up an issue on Github – I hope my suggestion is right :innocent:

EDIT: No success. Follwed your suggestion and didn’t touch the reboot-process. After a while (2mins, 10 reboots ors so) it just changes to the other slot where the working stock is booting without problems.

EDIT2: gougeon-s corrected the issues with the script. thanks!

I’m gougeon-s ;).

  1. Did you check that both slots had “success” ?

If not, go to the Troubleshooting tips part.

  1. Did you erase the userdata ?
    fastboot -w

ah, I already did suspect :wink:

  1. and 2. definitely yes… I seem to be a hard case.

When installing stock ROM it reboots and the stock recovery asks to make a factory reset. Therefore I also tried to flash without TWRP installed (just booted it for installing magisk). It came to the point, that stock recovery asks to make the reset, but again no change to the reboot cycle…

I also tried to flash just a single slot, both the same time, I tried to wipe userdate by TWRP after installing, tried to reinstall magisk after flashing… So far no bootable GSI LOS :-/

1 Like

Has someone tested the /e/? https://forum.xda-developers.com/project-treble/trebleenabled-device-development/e-rom-t3960376

2 Likes

Hi @all, i flash the la OS 17 and then 16. now my FP Hang on bootloader. I flash the stock with the script (twice) but same Problem, it Hang in bootloader. When the script flash i got 2 “ERR” like partition size magist.
I will post the ERR later if you need, but what can i do? And where is the Problem?

THX

We need the errors to answer…

Edit : I’ve seen you’ve edited the wiki to add something about the 30secondes warnings. Does it mean you managed to flash the stock rom?

i tried some gsi images:

not booting (one reboot, then boot to recovery):
/e/ image (e-pie-20190827-UNOFFICIAL-treble_arm64_beN-img)

booting:
aosp 9 (AOSP 9.0 v123 system-arm64-ab-vanilla-nosu.img)
ArrowOS (system_arm64_ab.zip 2020-01-27)
lineageos 16 gsi (lineage-16.0-20191017-UNOFFICIAL-treble_arm64_bvN.img)

edit: my fault with lineageos16, had to factory reset after flashing. Now it works

that was me. I just “forgot” to check the 30s warning to get the slots succeed again… Maybe others do the same stupid things as i did…

Nice ! And what was the errors?
I had LOS 16 and I confirm it works :wink:

here the fastboot log.

fastboot getvar all say say the slots are

(bootloader) slot-count:2
(bootloader) current-slot:a
(bootloader) slot-retry-count:b:7
(bootloader) slot-success:b:No
(bootloader) slot-active:b:No
(bootloader) slot-unbootable:b:No
(bootloader) slot-retry-count:a:7
(bootloader) slot-success:a:No
(bootloader) slot-active:a:Yes
(bootloader) slot-unbootable:a:No

Slot_a.txt.pdf (21.8 KB) Slot_b.txt.pdf (21.9 KB)

I only missunderstood the 30 seconds warning… always choosed reboot in bootloader to flash again or try something different. But i only had to confirm the warning with power button. stupid shit :smiley:
I now got lineageos working, had to do a factory reset after flashing… next i’ll try booting /e/

1 Like

It is a bit weird that current-slot: a is before the flashing lines…

If the errors you’re talking about are Invalid sparse file format at header magic, it doesn’t matter. It is because these images aren’t sparse files but it works.

Please referre to Troubleshooting Tips > To get a slot-success=Yes Post #1

If you see the 30secs warnings, you have to confirm booting with the power button.

ok it works… schame on me, i forget to confirm on the 30sec warning xD

edit: It is a bit weird that current-slot: a is before the flashing lines…

wrong copy paste :wink:

1 Like

“a tip for the first post.”
if fastboot -w fail try fastboot erase userdata

still have to do a factory reset vie recovery afterwards

Maybe “uninstalling” the unnecessary priv apps instead of disabling them could be the better way. In the Thread Google apps keep reinstalling someone mentioned that it would be better to use

adb shell pm uninstall -k --user 0 com.qualcomm.qti.qms.service.telemtry
adb shell pm uninstall -k --user 0 com.qualcomm.qti.qms.service.connectionsecurity
adb shell pm uninstall -k --user 0 com.qualcomm.qti.optinoverlay
adb shell pm uninstall -k --user 0 com.orange.update
adb shell pm uninstall -k --user 0 com.orange.aura.oobe

instead of

adb shell pm disable-user --user 0 com.qualcomm.qti.qms.service.telemetry
adb shell pm disable-user --user 0 com.qualcomm.qti.qms.service.connectionsecurity
adb shell pm disable-user --user 0 com.qualcomm.qti.optinoverlay
adb shell pm disable-user --user 0 com.orange.update
adb shell pm disable-user --user 0 com.orange.aura.oobe

for preventing uncontrolled reactivating of those apps. But maybe this is a stock rom problem only.
By the way: it should be ok to remove com.qualcomm.qti.qms.service.trustzoneaccess as well:

adb shell pm disable-user --user 0 com.qualcomm.qti.qms.service.trustzoneaccess

You should not disable com.qualcomm.timeservice.

works, good guide, thanks for the work @all here.
feel mutch better not longer to be under the surveillance of google & partner, and to be root again :wink:

1 Like