How to find out what micro-SD card is installed in my phone

Hi,
Is there a way to find out the details of the card in my FP3 without dismantling it?
Regards,
John

You only have to take the battery out ?? Are you sure you have an SD card ~ check Settings > Storage and look for the SD card with an eject symbol to the right.

I moved this exchange to a new topic, to “keep the wiki working”.
When a wiki is modified, it pops up in the list of latest postings.

Replying to a wiki has the unwelcome effect, that this doesn’t work any longer.
The wiki-posting can still be modified, but the (now) thread will only pop up, when a posting is added at the end of the thread.

I have added an explanation to that regard at the beginning of the wiki post as well.


Btw:
I have no idea, if that works, but maybe some details are listed, when you connect the phone to a computer (though tbh I am really doubtful, that it works).

I tried to find it out myself the other day but haven’t really found something useful.

Android does have the usual Linux /proc and /sys virtual filesystems, but the relevant entries can only be read as root (and my FP3 isn’t rooted).

I’ve read about the SD Insight app, but on the FP3 it isn’t found in the Play Store, because it only is supported up to Android 6.
I guess it has the same permission problems in higher versions of Android as with directly reading from /sys.

2 Likes

Sorry BertG,

And thanks for your efforts.

John

1 Like

Hi Ingo,

My computer runs Linux Mint 20.

I accessed the FP3 via Cx File Explorer, opened the SD card in Terminal via sudo and explored the directory structure, but I couldn’t see anything useful.

I tried netting across to root, user, admin and my_Fairphone_3 (which I got from arp) using ssh and sudo ssh but got a ‘Connection refused’ every time.

Once all else had failed I tried the simple option.

I connected the FP3 to my computer using a USB-C to USB 3.0 cable.

I set the FP3 ‘USE USB FOR’ to 'File transfer.

On the computer Nemo 4.6.5 listed ‘FP3’ in ‘Devices’.

Opening ‘FP3’ showed ‘Internal shared storage’ and ‘SanDisk SD Card’.

Right-click then Properties on ‘SanDisk SD Card’ showed
Name: SanDisk SD card
Contents: 133 items, totalling 631.9 MB
Location: mtp://Fairphone_FP3_A209F8Y80202/
Free space: 15.3 GB

(I then tried ssh to Fairphone_FP3_A209F8Y80202 but that bounced too, as did mtp://Fairphone_FP3_A209F8Y80202 .)

So it looks like I have a 16GB SanDisk SD card but I’ll have to open my FP3 up to find out the details.

Regards,

John

Well, with SanDisk it’s rather easy:
If it’s red / grey - it’s an Ultra
If it’s red / gold - it’s an Extreme
If it’s red / black - it’s a Pro

And the color can even be seen without opening up the FP3, as it has an translucent back cover.
With the FP3+ you have to open up the back-cover though.

4 Likes

It’s red / grey - and you were right.

It’s a SanDisk Ultra 16 GB microSD HC Ⅰ (10) A1

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.