How to be sure you send an sms and not an mms?

Question is in the title.

I do not need mms and they usually cost way more than sms if I’m not mistaken.

Is there a way to “force” the messenging app to use only sms?


I do not know of a way to force SMS only, but generally speaking whenever there’s only text (no attachments) it’s sent as SMS. Also, when sending an MMS, the text “MMS” appears above the send button next to the text input area.



Text messages are converted into MMS after the message exceeds the size of 3 standard text messages. There isn’t currently an official way to prevent this from happening.

There is an unofficial method to fix this which I currently use, but I’d only recommend it if you regularly send long texts and you understand the risks involved (i.e. you’re more than a novice with Android).

The official solution for now would be to shorten your text, or send as multiple texts. You can tell when the message has turned into an MMS, because the messaging app tells you (as @Jerry has already pointed out).

The unofficial solution is replicated below from the old forum:

Install the Xposed Framework:

  1. Click on this link from your phone to download the Xposed Installer APK, then click on the download to start the installer:

  2. Launch the “Xposed Installer” from the Apps menu

  3. Go to the “Framework” section and click on “Install/Update”

  4. Once the update has finished, click the “Reboot” button

Now install the “Disable SMS to MMS Conversion” module:

  1. After rebooting from the above, Launch “Xposed Installer”

  2. Click on the “Download” section

  3. Scroll in the list to find “Disable SMS to MMS Conversion” and
    click on it

  4. Click on “Download”, then click on “Install” when you get a
    pop-up. Then click on “Done”

  5. Once installed, you’ll get a notification message on your status
    bar saying that the module is not active. Click this message (or go
    back to the main menu on the Xposed Installer and go into the
    "Modules" section).

  6. Click on the tick box next to “AllowLongSMS” to enable it

  7. Reboot, and done


Thanks for the heads up! :slight_smile: