How to be able to install and use any app on FP Open OS [meta discussion]

It’s possible too, maybe it’s just xposed or just root or both. I don’t know but if someone does the test, I will improve my post :slight_smile:


I have FPOOS since a few months and until now I had problems to make some apps run, some displaying a message on launch saying they need Google Play Services, but then when you clicked Ok the message would disappear and the app would run perfectly. But some did not run at all (like Google Maps for example).

Now, I’ve started from scratch. I’ve successfully installed FPOOS 16.12.0, and installed XPosed Module “This App will run without Google Play Services” like explained in step 4 of this tutorial (✏ How to install any app on FP Open OS (for beginners and experts)).

And to some extent, it works. The apps no longer display the pop-up message saying they need Google Services. And apps like Google Maps run smoothly.

The only thing is that a lot of apps generate a notification now, saying “app won’t run unless you update Google Play services”.

Given the configuration explained in the tutorial, is there a way now to “update” the faked Google Play services, or do I have to live with these annoying notifications?

Thanks a lot in advance for your advice.


Which Apps are these and do they work other than generating that message?

The XPosed module you installed was last updated in 2015 and worked for every GMS update. So I wouldn’t wait for an update of that module.

Instead I’d try the very next step in the guide. “Mocking G%§$e with microG” will not only suppress those messages but also provide free alternatives to some of the G%§$e Services, so even more apps will run smoothly.

The apps that do it are for example The Guardian, Le Monde, Xperia Clock, … and yes, they do work, there’s just this notification now and then that’s quite annoying.

You’re suggesting step 5 in the guide. Do I really have to start from scratch and wipe the phone if I’ve done step 4?

Can the phone be rooted again afterwards?

No, you don’t have to do the full Level 5. The last point in Level 4 is to install another XPosed Module and then do only Step 5 in Level 5.

Alright, I’ve done level 5, and it seems to be fixed now.
I’ll be back if it’s not. :wink:

Thanks a lot for the very quick help, much appreciated!



Hi guys,

I’m very happy with my rooted fairphone. However, to access my company e-mails I need to install microsoft intune, which won’t run on a rooted phone. I tried running Root Cloak, which didn’t do the trick.

Although I was just getting into Xposed and all possibilities with a rooted phone, I am afraid I have to get back to being unrooted for the time being.

I googled and looked on the forum, but I didn’t figure out how to “unroot” my rooted device. I would like keep the FP open system. Any help for a newbie?

I don’t think FP Open can be un-rooted?! Since root is built-in, you can only hide root, not remove it.

Thanks retsipf for your reply.
I found this threat on “installing any app”. Reckon I have to use step 5. Step 0 is straight forward, but can someone tell me if I need both 1a and 1b?

Step 1a: Patch the framework.jar with Tingle to be able to spoof signatures.
Step 1b: Uninstall root.

Level 5 is for tricking apps to believe you have an unmodified OS (with GAPPS but without root). If you know that the app only has an issue with root and doesn’t care about Google, you only have to do Level 5 Step 1b - otherwise you’ll have to do the entire Level 5.

Thanks a lot! Also for moving my discussion to this topic, very helpful!

As far as I read my company policy, it doesn’t care about google and only complains about root. So this should do the trick.

Hey there!

I installed and set up microG on the Fairphone 2 (open os) by following this guide.

In the self-check-test, I have all boxes checked, without the last one (address localisation/address resolution):

In the settings, I can’t configure a service for this. I guess, it’s because I didn’t install an app for this.

What do I have to install to solve this problem?
Thank you for your help!

You still have to install and configure NLP backends from F-Droid.

Thank you for your answer!

I have already installed MozillaNlpBackend. Which other app do I have to install? Or how to configure MozillaNlpBackend?

Oh sorry, yeah the “Ortungsdienst(e) eingerichtet” check means you have Location backends set up.

Do you have the nominatim backend? It’s not necessary to locate yourself, it only provides Address data for the provided Lon & Lat Data.
If you don’t have that enabled or if you are somewhere where the OSM Project has no Address Information, then that box will stay unchecked.

1 Like

Thank you. The Installation of nominimatim backend solved the problem!:slight_smile:

1 Like

I don’t know how edit my post so I will answer to this one.

I tried different techniques but not with [quote=“paulakreuzer, post:90, topic:22327”]
Systemless Xposed

So you need to do at least step 1a, step 5 and step 6 of level 5 in How to install any app on FP Open OS (for beginners and experts).
After that in microG parameters you need to activate cloud messaging, terminal registering and google safetynet. This is it, you can install Snap and log in without troubles :wink:

You can’t use Xposed with Fake Gapps instead of Tingle (I didn’t test Xposed with Systemless Xposed) and you don’t need to unroot your phone :slight_smile:


I use latest Lineage with MicroG and Tingle on a FP2 and most of the stuff works pretty well. However, there is a problem with very few apps. When I try to install them, I get the following error message:

“requires unavailable shared library”

You will see this message in the logs or if you try to install the app via adb. I have a Samsung A310F on which I use the exact same configuration (latest Lineage, MicroG, Tingle) and I get the same error message there. After some research, I found a website that describes the problem:

Since I was not able to locate those two files in a GAPPS package (I used the OpenGAPPS packages), I did some more research and ended up at the NoGAPPS project on the XDA forums. I used this with my old FP1, but when I heard of the MicroG project, I changed to that. It turned out, that the solution for my problem is the flashable maps.api package from the NoGAPPS project. It contains the two missing files. Here is the link to XDA thread:

My suggestion is, to add this information to the tutorial, even if it does affect only very few apps.

1 Like

Feel free to do so. :slight_smile:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.