How is it possible, on a Fairphone 5 with /e/OS, to install apps I paid on the Google Play store?

Dear Fairphone community,

I have a a Fairphone 5 that I switched manually to /e/OS.
I can use adb as root.
Everything works fine.

I just need one more application that I paid on the Google Play store.
I am ready to install anything related to Google so that it works.
I do not want to debate why I use /e/OS and still want to use Google (in short, let’s say that it is a matter of time for now).

I installed the application through Aurora store, I was connected with the Google Account that I had used to pay the app. I was not requested to pay and the installation went through easily.
The application starts but behaves as if I had not paid it.

I tried to install Open GApps but it complained that I used version for Android 11 while /e/OS for FP5 is based on Android 13. I did not find a version higher than 11 on https://opengapps.org/.

Is there a way to download some APKs for Android 13 including the Google Play Services maybe and the other related APKs that might be needed for everything to work ?

Another point : when I had switched my FP2 to Fairphone Open OS I think I had managed to use the paid feature of this app. Am I correct if I say that there is for now no possibility to install FP Open on a FP5 ?

Any help would be appreciated, thanks in advance.

Not sure thats possible. You cant install OpenGapps on top of microG.

If you want CustomROM with Gapps you have to wait for LOS.

For Paid Apps: this does not work for in-App payments and only when you paid the whole app… i dont have issues with this, however only have 1-2 Apps I paid for.

Yes FP Open OS does not exist since FP3 and no you did not pay for it.

3 Likes

Perhaps you can contact the app in question and ask them if there is a way to get the paid version working.
Years ago I succeeded to get the paid version of the app Titanium Backup working after I contacted the people behind the app.

4 Likes

There’s MindTheGapps … Download MindTheGapps: Custom Google Apps Package for Android
But @yvmuell is right, this doesn’t help you on an OS including microG such as /e/OS.

On iodéOS you would be able to uninstall the included microG, but MindTheGapps seemingly doesn’t help there either … Mindthegapps instead of microg? - iodé community

So LineageOS should indeed be your best chance in Custom ROM territory.

Aurora Store can do the installing, but In-App-payments and In-App-licence-checks are a problem.
If the issue is a licence check you could reach out to the developers and ask whether they would be able to offer other options (licence file/installer/anything).

Not only for now. There is no Fairphone Open OS anymore.
Fairphone have an official partnership with /e/OS instead now since the Fairphone 3 times … Keeping your data safe with /e/OS - Fairphone … and in general they keep the Fairphones open for installing alternative OSes.

3 Likes

Yes, FPOpen has been discontinued for a long time. Fairphone only does FPOS but supports custom rom devs, especially /e/os and CalyxOS.

You can’t. In short it’s not possible to install opengapps alongside microg which /e uses.

The app probably uses google play services to verify a license or something similar. It that case, you’re out of luck, this won’t work in /e.

I use CalyxOS that also has microg. Normally, an app that you buy directly on the store works when downloading with aurora store and your account. But all the in-app purchase cr@p doesn’t work (which imo is a good thing). But that also means apps, that in-app activation of premium features, or license checks through google servoces also won’t work.

Apart from contacting the app developer the only other option would be to switch back to official android, i.e. FPOS.

1 Like

I had tried to uninstall microG.

FP5:/ $ pm uninstall --user 0 org.microg.gms.droidguard
Success
FP5:/ $ pm uninstall --user 0 com.google.android.gms
Success

But maybe you are saying that this might not be sufficient ?

I gave a try to MindTheGapps but it fails with a strange error related to memory (FP5 is not that small and I just have a quite vanilla /e/OS) :
Low resource device detected, removing large extras
Not enough space for GApps! Aborting
Cleaning up files
Unmounting partitions
ERROR : recovery: Error in /sideload/package.zip (status 1)
Install completed with status 1.
Installation aborted.
I also tried with NikGapps but I ended with a boot loop in fastboot mode so I reflashed the OS.

Now my idea is to try to get all APKs from FPOS and to install all of them on /e/OS and to test if with these APKs (and with microG still removed) my paid app will work.
I am currently in the process of installing all of the APKs on the FP5 (they are already extracted and moved).

That’s what I plan to do, this is the long term solution.

This is not an in app purchase, this is a yearly subscription.
As said, it works fine on FP Open OS so I believe there is some hope :slight_smile:

Sounds like a bad idea…and I dont think e/os forsees to run without microG or that you can just easily remove it (def not without root if at all).

Imho iodéOS solved it better - the option to uninstall preinstalled apps (including microg).

See

2 Likes

I think you are right.
For now I just managed to get a phone that suddenly stops. It then failed to boot. It showed a recovery screen indicating that it fails to start and proposes to wipe data. I wiped data and then could again boot /e/OS.

Thanks for the idea, I did not know this OS.
I will try to install it.

The status for now is that I installed Iode, I deactivated microG from the settings but still I was not able to install any of the versions of Google Apps I know.

  1. MindTheGapps
    adb sideload MindTheGapps-13.0.0-arm64-20231025_200931.zip => signature error
    I later tried to fastboot boot TWRP then Install the zip but I ended on a boot loop on fastboot.

  2. NikGapps
    adb sideload NikGapps-core-arm64-13-20220908-signed.zip => signature error
    I later tried to fastboot boot TWRP then Install the zip, everything seemed fine in the logs except an error that it cannot mount the “/data” partition. When I restarted on Iode, I did not see any new app.

  3. OpenGApps (the highest version I found was for Android 11, I have Android 13 so not tested on Iode, it had failed earlier on /e/OS)

So for now I plan to keep using this app on my old FP2 until I find a better way.

Thanks to all for your help! It was nice for me to have your answers so quickly.

you cannot install GApps to e/OS or IodeOS, thats just not possible.

As you dont have issues to use some Google, why dont you just go with FPOS and deactivate as much Google as possible?

I try to get as less dependant to google as possible so switching to an OS without Google as base is a first step for me. I would also like to learn which of the apps I use or need are GSF dependant.

Can be done.

Can’t be done with switching to other Android OSes. They all use Google’s work as a base (AOSP) and will still have most of their code written by Google.

Aurora Store shows this in its App search results.
This doesn’t say how much trouble an App would have exactly without GSF, might be negligible, or might be breaking the App … but it sure is an indication to have an eye on.

1 Like