How do I install OpenGAPPS?

If I understood correctly, you would probably need to flash it via a custom recovery. Alternatively, you could also try to use Flashfire, but I had no success with it so far.
There is also an option to flash a .zip file in the standard recovery via adb sideload, but it seems to be insufficient for most deep rooted changes. But I haven’t really fully grasped the difference yet. MAybe someone could elaborate?

hm, most of it is a bit alien to me… I was hoping to find a step-by-step instruction.
It is kinda weird that their download page is so easy and nice but then there is no documentation on the site or wiki at github on how to proceed…
Could it be the procedure is different on different devices?

Hi everyone,

I feel quite stupid for this question, but how can we install openGAPPS on Fairphone Open OS?
When I download a package from their website, I get a .zip file… can anyone tell me please, what to do with that?

I got my Fairphone today and I am considering installing the Fairphone OOS.
So right now I am still downloading the repo and I want to try to compile it later on. The question whether I actually try to flash my Fairphone depends on how flexible I will be to install google apps later on.
(This is my first Android Smartphone and I cannot yet see if I will be able to live without the Google Play Store).

On the openGAPPS FAQ there is no entry for “how to install”, so it must be something super obvious I am not aware of…


1 Like

I do not use Gapps, but I assume they just get sideload’ed (or with an SD card with the .zip on it) using a working recovery best on a clean install.

Update: "Open"gapps is a pretty obscure project. It’s best to report your problem there as well, so they can fix their FAQ. They should also fix their their name as well, it’s misleading.

How is their name misleading? You mean 'cause it sounds like it is a google project of some sorts?

But yeah… I can not imagine their FAQ is an actual FAQ… seems more like some questions they wanted to answer then most asked questions :wink:

No, but because the only thing open about openGAPPS is the way they are installed. In fact the apps are identical to GAPPS, nothing open about them, as discussed in this topic. (Which is where I moved the previous two posts from)

1 Like

Back to the original question!

I installed FPOOS now, with TWRP.

I tried to install openGAPPS pico, but don’t succeed.
It seems to work to install the zip file from the recovery. MD5sum is OK. On the next boot it optimizes 12 apps. It also asks for credentials and set up.
However, after the OS is started, GAPPS crashes: “Google Play Store was closed”.
The same happens when trying to open the play store from the app menu.

Is there anything else that need to be considered when installing openGAPPS?
I was thinking maybe privacy impact could be issue, because it never asked about opening the play store (though it is enabled).

@freibadschwimmer: I use CM for my T315 and there it’s only working when the OpenGAPPS are flashed at the same time as the OS. Maybe this is the case with FPOOS, too?

1 Like

Would be worth a trial, I just can’t figure out how.

When I install the osos with the command

fastboot update

it automatically reboots the system afterwards; so I don’t have the chance to install the openGAPPS before that.
Any suggestions how to do/try that differently?

You could try it with TWRP :wink:

1 Like

Did try it :slight_smile:
It didn’t work with twrp to flash the osos zip, probably because the zip also wants to erase and reinstall the recovery.

Maybe it could work to extract the archive first and only flash the other partitions again (i.e. system and data), and then opengapps.

@lklaus suggested to turn off location, which also worked for me.

So apparently the installation went well. No need to flash it together with the system, just simply installing it via TWRP. After turning off location, the play store works.


I confirm that behaviour. After turning off location, the play store works fine.

I tried to install it with TWRP on FPOSOS now, but it just tells me that it failed, because the zip signature verification failed. Any ideas what I should do? I assumed that I have to download the ARM for Android 5.1…

Uncheck the zip-verification


That did it - thanks a lot! :slight_smile:

I tried FPOSOS and then with the help of Raccoon I placed some apps from Google to FPOSOS. This doesn’t work of all apps and especially not for paid apps.

Is it possible to use a paid app from Google if I fetch it by OpenGAPPS?

OpenGAPPS is an installer for Google software, so it will install Google Play Store which works the same way as on the GMS OS version.

In other words: yes, after using opengapps you have access again to your play Store account and software.

Edit: the advantage of openGAPPS is that you don’t need to install the whole GMS but you can select which parts you want to have, i.e. in the minimal version just the framework and the play store.

1 Like

Yes I got it right. First FPOSOS and then Opengapps.
Installing Opengapps was a little difficult, because I tried to restore instead of install.
But finaly I succeeded :smiley:

1 Like

This might have been answered somewhere else already but I wasn’t able to find an answer:

When using standard GMS, push service for apps like Whatsapp is provided by the Google framework (I hope that terminology is correct), right? Is that also included in (all/any?) OpenGApps flavours?