How do I install f-droid on lineageos

I am sure this is an easy question but I cant get it. I want to install f-droid on my ff3 with lineageos 17.1
I go to and click on download. the screen flashes for a moment and this is it. In the files app in teh downloads section I see an android logo and a comment: in the waiting queue. But this never ends.
It stays there.
Any idea?
PS: Yes, I followed this hint How to Install Apps From Unknown Sources Android 9 Pie – BestusefulTips
how to allow unknown apps to install .
But also certificates are not stored, I just see it is waiting.

Open the file manager, search for the folder “Download”, open the folder and you should find the F-Droid.apk there. Click on the file and the install process starts, here you must now allow the installation.


Well the filemanager tells me: queuing and waiting. It seems not to download the apk.
Although Internet works else I could not go to

It seems to me like you can’t manage the download to start properly. Maybe you consider doing that by an external computer and move it via usb cable. Otherwise bluetooth sharing from another phone might be an option.
Long shot guess: are you using an sdcard and do you have it included as internal storage? That might lead to strange behavior on LOS too.

1 Like

figured out what the problem was. I use a firewall which strangely worked with android but seems to have blocked lineageos. now it works. uff.
makes life with lineageos easier


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.