English

How can I recover lost/ deleted data (photos etc)

Hi!
I accidentally deleted all photos and, of course, there is no backup available. After some research online, I tried to run data-recover software (Recuva and DrFone). Unfortunately, the FP was not recognised as device, nor was it on the computer (mass storage). Therefore, the programs did not complete. Since it happened, I kept my FP in flight mode to avoid any overwriting. How can I fix this? How can I “save” my lost pictures?
Thanks!

If you saved your photo’s on the SD card, you might take it out, and try recovering the photos from a PC with an appropriate card reader.
If not, I wouldn’t know how to get them back.

Good point. This might actually also work with the internal memory. I haven’t tested this, so please, @Paihia, don’t be mad if I am wrong. I realise that you already tried recovery software, but you could also try this one. It’s a bit technical at first, but pretty powerful. I think that Piriformes’ Recurva does not recognise Linux file systems, but PhotoRec does. So it’s worth a try, maybe?

Careful, it might also recover data which you do not want to restore and fill your directory with crap.

Just BTW, I doubt you kept your FP in flight mode for a week, but if so, it might have helped. I certainly hope so.

That would require raw access to phone storage, and I have no clue how to access the internal memory as a raw device, but I’d want to learn (just in case I ever encounter the same situation).

If the lost data was on the SD card, I can assist in the recovery.

Hi there!

I got in a similar situation when I accidentally switched on the factory mode and got all my data deleted :persevere: As I am not that well versed in these questions, please bear with me and correct me if I am wrong.

Photorec did not recognise my usb connection so it could neither recover the data :sweat:
Maybe you need “USB debugging” so that these recovery programms can work properply?
Or is there any software that can recover data from an phone that is connected via cd-Rom?

I would be very grateful if sb would find a solution :blush:

Tools like Photorec need low-level access to the storage medium. I don’t think it’s possible directly over usb, as in the normal way you connect to a PC (MTP, PTP).
Maybe it can be done through adb, or maybe by physically hooking up some kind of debugger to the phone’s mother board. I don’t have any experience with this, but I’m curious to know though…

Sounds a bit like what @jpjacobs said would also apply here. Did you try it? Could you report what happens?

I’m closing this off for now, to avoid the reoccurring spam posts. If you need it reopened, please flag it up to the moderators.

This topic is now closed. New replies are no longer allowed.

2 Likes