Hotspot Error - automatically shuts off

I have seen other posts on the Hotshot issue which are now locked. I have the same issue:

Hotspot shows “error” in settings
Going into settings and changing everything does not correct the error:
Changing hotspot name
Switching to 2.4 or 5 GHz
Changing security options
Disabled Auto-off

Turned wi-fi off and on
Rebooted device

Every time I turn the hotspot on it immediately shuts off again.

Is there a solution to this?
Many thanks


Hi and welcome to the community.

Which other topics are you referring to? They could be re-opened.

Most recent issue is, that you can only use a 2.4 GHz Hotspot and it might be you need to turn Wifi off, to be able to establish the hotspot, is this what you mean by “turning Wifi on/off”?

Btw. Which OS in which version is installed? did it ever work?


Hi Yvonne,

That was one of the topics I viewed.
What I mean is that no combination of hotspot settings, or changes to the wifi/bluetooth settings, allows me to use the hotshot on my FP4.

I have tried everything I have found either here or on general android help sites, and the hotspot just refuses to turn on at all.

Android v 12

kind regards

This might be because tethering is not allowed by your carrier. Did you check?
If that’s the problem then there may be a work-around.


Thanks for the idea. This has till now not been the case. I have been able to hotspot on every phone prior to this one, and my plan has not changed.

To be absolutely certain though I just checked the T&Is for my provider and the function is listed there.

This looks either like a hardware or software thing.


In that case can you check the details of the APN you’re using.

Settings > Network and Internet > Mobile network > Access point names > [tap on the APN] > APN type
needs to contain “dun” either upper or lower case.

If that value is absent, you may be able to add it manually (don’t forget to save your change with the three-dot menu top right). However, nowadays carriers often set APNs read-only to prevent users from messing about with them. In that case I’d advise you to check with your carrier in the first instance.

If the value “dun” is already present for the “APN type” list we’ll look elsewhere.

From the point of view of the device and the OS version you’re running there should be no problem using the hotspot feature, I used mine yesterday.

1 Like

Mine does not contain dun and works, so is this specific for some provider?

To test I think one could just create one manually duplicaring all entries and choose this to test…

Definitely. I’m using it daily lately since I’m far from home and use exclusively my phone to access Internet: It’s much faster and way more secure than hotel or client WiFi…
It works very well, except under Windows 11 where most of the time I have to manually tell the computers to connect to that SSID. Linux/Mac do connect automatically.

Note there is a feature which automatically switches the hotspot off (to save battery) when no device is connected to it, and when it does, it will give you an error on the top status bar. Given the thread’s actual title I thought you meant that.
This automatic switch-off is actually a good thing (I do sometimes forget to switch it off when leaving in a hurry…), but if it bothers you, you can disable it in the WiFi hotspot settings. It doesn’t change anything to hotspot reliability anyway, if a device is connected to the hotspot, it will stay active for as long as the phone has enough battery and a mobile data connection.

So I have looked at my settings and compared with someone else in the house.

We all have the same provider, and their phone (Redmi Note 9) has no issues with the hotshot. I checked the APN settings and there was no difference between theirs and mine.

This leads me to think this is either a Fairphone hardware or software issue.

One setting that is causing issues somehow sometimes is the APN Protocol. If yours is set to use (as well) ipv6 switch to ipv4…

Hi, checked this too, and it was also IPv4 for both APN Protocol and APN Roaming Protocol

And what values did you find for the “APN type” field?

Bear in mind that carriers vary in the way they treat services like hotspot. Often their treatment will also vary from one model of phone to another, so just because the hotspot works with a Remi Note 9 and same APN settings and same carrier doesn’t necessarily mean that your problem isn’t related to the carrier+phone_model combination.

I had the same issue, For me the solution was to go to Wi-Fi hotspot and set the AP Band to ‘2.4GHz Band’ instead of ‘5.0 GHz Band Preffered’

Hope this can help.


Welcome to the forum.

Yes, this is a known factor. But if you look at the early posts in this thread you will see that the OP had already tried setting to 2.4 GHz without result. There’s also a reminder of this in post #2.

I currently have the same issue, the Hotspot was correctly working before A12 update, none of the 2.4Ghz and 5Ghz options work, my only workaround for now is:

  • turn on plane mode
  • turn on 2.4Ghz hotspot
  • turn off plane mode

And here you go the hotspot is now active.
But yeah this is a strange issue, and it would be lovely that fairphone fixes it :confused:

Hi and welcome to the forum.

As this is a user forum, Fairphone do not usually read topics they do not create, so you may want to contact them directly if want them to see your issue.

In my settings the values are:


I cannot change them, but also have not attempted to create my own setup.

Sounded like a thing, tried this, hotspot still shuts off immediately.

However I may open a ticket. Thanks for all the ideas and attempts to everyone on this thread. Sadly still not working.

Have a good day all

This likely means that your carrier is not offering the hotspot feature for your phone. That may be for various reasons, but the most likely one, given the Ts&Cs you cite, is that they haven’t tested the function with a FP4.

You didn’t reply to yvmuell’s question

nor mine (did you check with your carrier?)

I have seen other examples of this scenario (the feature is offered by the provider; it worked on a previous phone of the user; it works with other carriers, on phones of the same model as the new one).

Again, I advise you to check with your carrier.

My hotspot worked for only 50seconds every time …

Key to get it work reliably:

… that you can only use a 2.4 GHz Hotspot and it might be you need to turn Wifi off

==> turn wifi off
==> turn hotspot (2.4GHz) on
cross fingers …

btw. best webpage to check running/failing internet connection if not
using ping anyway:

1 Like