Hotspot doesn't work

Hi everybody,
this is my first time on this forum. I’m Daniele from Italy.
I’ve someproblems with the hotspot WiFi. I’m reasonably sure that the problem is in my FP2 settings. In fact, if I put the SIM in another smartphone, it works with no problem at all.
This is the symptom: I turn on the hotspot, then connect the device (computer, tablet, other smartphones…). The device sees the hotspot and on the FP2 I can read “1 device connected”. But it doesn’t work.
Is there anybody that have some suggestion? Many thanks!

Is your phone connected to mobile data while you turn on the hotspot? Does internet work on the phone at that time?

The FP2 is not able to connect to two wifi networks as the same time, you cannot use its hotspot to boost the range of your wifi. You can use the hotspot together with mobile data.


Thanks for your help, Albert. I confirm: my FP2 is connected with mobile data. I even switch off the WiFi connection, to be sure. Thanks again.

isn’t too specific. The devices say they are connected to your phone but you cannot access the internet from them, is that correct? Which OS is your phone running? Standard Fairphone OS or anything else? Is there any firewall or virus scanner software installed? If you connect a computer to the phone’s hotspot, can the computer ping the phone’s IP address? For instance on Windows open the commandline window, type
and search the Default Gateway of your WiFi adapter. Take the IP address and type
ping [IP address]
where [ip address] of course has to be replaced by the Gateway’s address.
If that is successful you know that the IP connection to your phone is up and running. Then you can do the next step: Ping an IP address on the internet, e.g.
(this is the IP address behind If that is successful, too, you know that in general the connection works but you may have a DNS issue where the domain name cannot be resolved into an IP address. To find this out you can run

Based on the results you can then check where to continue your investigations.

1 Like

Many thanks for your help, Martin. Yes, your description is correct: there’s connection but internet doesn’t work.
About the OS: is Android 7.1.2.
About the ping: unfortunately I have a Mac. I use ‘terminal’. When I write ping
the answer is
ping: cannot resolve Unknown host
when I writw ping the reply is several lines with
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
and so on.

Again, many many thanks.

Okay, that means that DNS is not the issue but your computer cannot reach the internet at all. We still need to know if you can reach your phone. But I don’t know how to find out the gateway on a Mac…
But apart from that: Are there any apps on your phone that could have anything to do with networking?

Hi Martin, I don’t think so. To be sure I already did the reset.

Okay, you did check with another phone but still: Are there any indications that your provider doesn’t allow tethering? I’ve read that phones may tell the provider if traffic is produced via tethering. But I could also imagine that this functionality might not be implemented evenly well in all phones/Android versions or whatsoever.
If your provider doesn’t allow tethering but you still want to do that a proxy server on the phone could help. But I have no experiences with that, I just read about it.

Hi Martin,
Today I talked with the provider. Very kindly, they tried to help me, with no results. Where I can find some information on proxy?

I have no experiences with that, so let me google that for you

Problem solved! Thanks to the Fairphone assistance. I changed a parameter in the APN setting,
Nome: CoopVoce
MCC: 222
MNC: 1
Tipo APN: default,supl,dun
Protocollo APN e Protocollo roaming APN: IPv4/IPv6
Valore MVNO: Coop Mobile

and now it works! Thanks a lot for your help.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.