Hotspot but no internet on Vodafone UK (pay monthly)

Hi all

Anyone any luck with using FP3 as a hotspot with Vodafone UK? With me the hotspot functionality itself works (I tried this with different devices i.e. laptops) but without internet connection (i.e. I can get connected but without internet). Mobile data on the FP3 itself works.

I’m guessing this has something to do with APN settings (if this is something I can do anything about myself), but applying those as on [\] --> “setup phone internet settings manually” --> “Android” led to no avail. I contacted FP and they are hopefully now looking into a solution as well, but Vodafone couldn’t help me so far and I thought I’d post it here as well anyway (perhaps I’m just missing something, or, perhaps worse yet, my phone was ‘partially broken’ on arrival already?). I bought the FP3 new from FP and restarted it several times and took SIM and SD cards out several times already while trying to resolve the issue. One of the suggestions from FP was to perform factory reset and to test with SIM cards from family and friends, but those are steps I’m not very eager to take at this point in time (understatement).

Tested using different types of networks (4G/3G/2G) manually already, didn’t help. The SIM works fine with hotspot & internet with my old phone, a Samsung Galaxy S5 Active, so I’m just guessing it’s not the SIM card itself that’s causing trouble here. I also copied the APN settings that work on the S5 active to the FP3, also creating a ‘hybrid’ of network-automatically-provided setting and setting that worked on the S5 hoping that that might work, but none of these led to a working solution.

FWIW, I’m a Vodafone Pay monthly customer (as far as I’m aware). I’m seeing that there are apparently similar topics on this forum for FP1 and 2, but was hoping that this issue would have been resolved for FP3 already.

Thanks in advance for any pointers.

EDIT: this solution (“Mobile hotspot issue : no more internet connection”) apparently worked! (I preferred to try this one first rather than “Hotspot: wifi working ok but no internet conection” as it seemed slightly less invasive to me – the latter involved deleting a file…)


Exact and same issue to me: used the same SIM (Telekom, with large data plan) on FP3 and on older Sony phone. Hotspot works perfectly on Sony, while on FP3 is continuously interrupting internet connection, latest after a minute or so. I need to reconnect all the time which is extremely annoying. Various restarts and updates did not solve issue.

Hi, I just have been spending hours doing this myself. I followed the link from above and copied what Isbjoern said. But this didn’t give me any luck.

The main thing for me was adding dun under access point name>apn type. This is explained in the Nexus post, which you get to through Another’s edit link and then Isbjoern, and then follow the post under Ana Alltari.

I tried to edit my APN but it wouldn’t let me, I think as I am with Vodafone, so I had to create my own access point and copy all of the settings, there is a discussion here on how to do it. I just created a new one, screenshotted the settings, and then copied them onto my newly created APN.

When I got to APN type I had to add DUN at the end like this:

APN Type

The key part is making the dun caps to DUN, as the access point under Vodafone wouldn’t let me save this otherwise.

That resolved it and I had hotspot with internet


Of potential interest, to my pleasant surprise, I have functioning hotspot including internet access currently – hadn’t been trying this for a while (and frankly had basically ‘given up’ on the phone), and think it may be related to improvements(?) included in OS updates??? FWIW, currently it says:

Android version

Android security patch level
5 August 2021

Google Play system update
1 August 2021

Baseband version

Kernel version
#2 Thu Aug 5 15:13:54 CST 2021

Build number


Well you can now update to Nov 5th Patch :slight_smile: Network permitting ?

Build number

Hi there Rohit_Patro and welcome to the community forum :slightly_smiling_face:

I’m glad your hotspot is now working. Do you know which action you took enabled the hotspot problem to be resolved?

Thanks also for sharing this article. However having read it through I feel obliged to say, that while it covers a few basic checks, it seems to me neither comprehensive nor very well written. In particular, it lacks two very important ingredients for a working hotspot : the phone’s APN settings, and the other device’s Wi-Fi card settings. I’d much rather see these, than incite the user to do a factory reset … :smiley:

Do have a look round the forum, you’ll find plenty of peer-reviewed advice on hotspots!

1 Like

My spam sensors are tingling, but together with your competent addition it might be useful.
Future readers may want to mind the Affiliate Disclosure of the site linked to.

1 Like

That’s sooooo LOL! XD
And the worst part is that it worked for me as well; many thanks!

A bit of context:
Before reading this… solution, I’ve read this post, which explains how Google has surrendered to the “carriers” (T-mobile, Vodafone, etc.) so that it let’s them “specify which type of APNs are user configurable”. This is because it seems that some carriers have a limit on the amount of data one can tether, and this same solution can be used to bypass it. So now many carriers don’t allow the users to add “,dun” in the list of APN protocols to avoid them bypassing this limit. So, when I read about this solution I was sure it wouldn’t work. But it was easy enough to try. So I did. And it worked XD

Now bets are open: was someone in Google very clumsy or did s/he troll the carriers?

I find this story very amusing!

1 Like