English

Home screen displays Fahrenheit temperature instead of celcius

Hi everyone,

My question is short and simple: on my home screen temperature is displayed in Fahrenheit, not Celcius, and I seem to be unable to change it. When I click the temperature to go to the weather app, the temperature shows in Celcius again.

I realize that this may be more of an Android issue than a fairphone issue, but at this point I have spent many hours searching the internet for a solution without results. I have never used Android before, but it seems like the internal settings and options are completely different on every description I find on the internet!
PS if there is any way to remove the weather from the home screen altogether that’s good too. I don’t care about the weather conditions shown on my phone (I have a window for that purpose), but if it has to be there, it’s nice if I can at least read the temperature.

1 Like

I had the same issue. For me, it went away when I switched launcher to Lawnchair (I did not want the permanent Google search bar which I could not change to DDG either, hence I switched).

Thread about removing Google search bar (includes alternative launchers):

2 Likes

Yeah, it was °F for me, too.

Long-tap on the Widget, then hold and drag it to “Remove” to remove it from the home screen.

Try adding it to the home screen again then, it displayed °C then for me.
(Long-tap on the home screen - Widgets - Google - At a glance)

5 Likes

Thank you for the responses. A quick update: changing the language to UK-English and removing and replacing the widget did not work. I will look into the Lawnchair launcher once I have the time.

Ok, I had a look again after resetting the OS by unlocking the bootloader, and for me it worked like this now …

  • Tap on the temperature in the Widget, this will get you to the full-blown weather App.
  • In the hamburger menu there’s the temperature format toggle. It should be set to °C already (and the App should display °C, too), even if the Widget displays °F.
  • Toggle this setting to °F and back to °C and close the App.
  • Remove the Widget.
    (Long-tap on the Widget, then hold and drag it to “Remove” to remove it from the home screen.)
  • Add the Widget again, it should display °C now. (It does for me.)
    (Long-tap on the home screen - Widgets - Google - At a glance)
1 Like

I had the same problem, but for me it was very easily fixed. I opened the weather app and changed it to Fahrenheit, then changed it back to Celsius and since then it’s been displaying correctly. Might be worth a try?

1 Like