Help with Xprivacy settings relating to Google Apps

I am on 1.8.5 and have the exact same problem as desribed above. Tried all the mentioned tips. Is there anything else I could try to get the connection to the play-store services back up running?

Hi @Johannes_Kraus,
I take it that you also use XPosed, with XPrivacy? (@All people NOT using XPrivacy, don’t despair, we will find a solution in another thread. :sunny:)

Here’s my current status: :signal_strength: I’m totally blue! I am still under the impression that Xprivacy had something to do with my problem, but I can’t figure it out.I hope relating my story helps.

I did the update form Cherry to Cola Nut now, and I got back connectivity. (Also, everything worked smoothly, so my backup precautions were not needed this time; still, better safe then sorry…)

When I installed the pre-update (updating the updater app), Google apps was defunct, I got a prompt by the FP OS that I should not forget to reinstall it. I did not, but applied the update from 1.6 to 1.8.5. Then I installed GApps via the updater app. I signed in and got the blue WiFi icon. However, I got a prompt by TextSecure that I was not connected to GApps a moment later. It did refuse to even open. (WTF? Without even prompting for my passphrase!?)

I had to go through a number of reboots next, i.e. to re-activate Xposed, and turn off and on push messaging in TextSecure, and maybe some other stuff. (Can’t remember properly, shit. Should have noted everything down, but was working aside. Sorry, @all!)

I did not have to explicitely turn on XPrivacy (and GravityBox) back on after re-initialising XPosed, and their rule sets are still very much in practice.

Sidenote: every reboot let Orbot kick in, which in some cases prevents me to connecting to GCM. (I guess there are some server in the Onion sometimes which might cause problems - I also often have to proof I’m not a bot quite often when coming from TOR network.) I have to turn it off then to get a blue WiFi icon, which I do only on trusted WiFis - not in a hotel, coffeeshop, public transport, and so on.

However, now, I am up and running again since quite a number of apps (and also Google Play Store) updated after opening the Play Store app, and I did NOT open the XPrivacy settings, but swiped the notification away. As I said, the rule sets are still in practice, and I can see in the usage data that e.g. MMC and MCC are blocked when Android itself (i.e., Google Services; UID 10060) want to access that data.

After opening a recently updated app, e.g. Google Play Store, I get asked if this app can access $data, which I then can decide case-by-case, and always first in Expert mode with “once for 60 minutes” enabled to see if it crashes the app, disrupts your connection to GCM, or has any other unintended effects. (Warning: I think the latter is utterly important: always, really always test first when restricting any Google App or other parts which are build in or entwined with the Android system.)

If you are still stuck without GCM, and have been using the XPosed framework with XPrivacy, my current advice would come in two flavours, which I BOTH did not test myself, so there’s a huge disclaimer: don’t blame me if it does not work.

Flavour one (The as-may-options-as-spices-in-a-curry flavour):

  • [Optional: Turn off location access and maybe all other syncing with Google, in the ‘Google Settings’ app.]
  • Go to a trusted WiFi, or use a data connection.
  • Turn of XPosed (Uninstall). Not XPrivacy, but the whole framework. Note that according to the developers GitHub page, Titanium Backup can not make a full backup of the settings, and you would need a pro license to export your settings. I’m not sure about this about this, because I can restore Xprivacy from Titanium Back Pro, but then, we’ve got \root.
  • Reboot, and make sure you are not using TOR afterwards.
  • If not yet connected to GCM (see above how to check), open the app which relies on GCM, e.g. a messenger like WhatsApp, TextSecure, Threema. Try to renew your connection by either turning off push messaging and turning it back on (you may also try if a reboot in between helps) or by using something like a “renew push token” setting.
  • If not connected to GCM yet, open the Google Play Store, go to my apps, and see if you can update any. Otherwise, choose any other app to DL, install it - you can de-install it later.
  • If not connected to GCM yet, try to de-install your messenger app in question (after doing a BACKUP, of course, using a proper backup solution!), reboot, then re-install it. If your messages are lost, try to restore ONLY the apps data from the backup. If that does not work, restore the whole app with it’s data from the backup. (If that does not work, please don’t be mad at me, I’m just trying to help here.)
  • If connected to GCM again, re-install your XPosed Framework, reboot, and see if XPrivacy is a) installed, and b) activated. You can try to restore it from your backup, if not. Again: I did not try this, but I’m just trying to help here.

Flavour two (The here’s-the-grinders-for-pepper-and-salt, spice-up-as-you-go flavour):##

  • Please read XPrivacy’s GitHub page, especially the sections 63 (troubleshooting) and 9 (update ROM).
  • Go to XPrivacy, and in the settings, activate the Expert mode, and flush the cache. I think now you are bound to set all settings again, for each app. If that is not the case, you can try the “clear all xprivacy data” option.

(Please note, while this might seem the easier option, but you will have to set all your restrictions again, which is very annoying if you use many apps.)

Now, I hope this helps. As I said, I’m connected to the GCM servers again, and I don’t know if ANY of this might help you. The two-flavour suggestions are just suggestions. If you try any of this, however, it would be really nice of you to report back what worked, and what did not.

Given my own track record of not remembering th exact steps of doing, it might be a good idea to copy-paste the suggestion followed, and just tick stuff off, and make short notes what happens. :wink:

2 Likes

I moved a post to an existing topic: Phone not connected to Google Play Services after every reboot