English

Help with phone getting stuck on 2G

Hello! I’ve got a weird issue and I wanted a bit of help to try and debug.

This happened on my FP2 and continued with my FP3. I’ve never heard anyone else report this.

Basically, I realised that when I was on the tram on my way to work in the morning that my FP2 was stuck on EDGE. Nothing would get it to connect to 3G, or 4G, beyond a reboot. Eventually I worked out that on the FP3, if I went into the “Preferred network type” and flipped it to 2G, waited a second, and then put it back to “2G/3G/4G auto” then it would immediately connect as 4G. Turning mobile data on or off, or putting it into airplane mode wouldn’t work. I could leave the phone ALL DAY and if would never reconnect to 4G without that restart or flipping that setting.

At first I though it must be an odd bug with the FP2 as my phone provider (who I work for) could find no reason for it, but it’s follow me when I moved to the FP3!

My house has very poor signal when indoors, so often when I’m connected to my WiFi, my phone displays an edge connection. Not all the time. I’m wondering if overnight, the continued flipping between edge and 4G puts me on some sort of naughty list on the providers side perhaps? Either that, or it’s just a bug in FP code?

Almost every time I go out for a run using my phone, I’ll get 2-3 songs into my Spotify playlist and it will cut out. I’ll get out my phone and realised that it’s stuck on edge and I have to flip the settings. It’s really really annoying and weird!

Any ideas?

Strange, indeed.
We can assume the SIM card is a different one because of the change to nano SIM (and not a cutout of the former micro SIM)?

Did you try whether the behaviour is the same if you put the SIM card into the other slot?

Can you borrow a SIM card of a different provider to check whether that would make a difference? Or check your SIM card in a different phone?

2 Likes

I’ve had new sims since then to see if it was that but it didn’t help. I’ll try swapping my sims around and see if it follows to the second slot.

Changing slots hasn’t helped. Same issue in the 2nd slot.

Which country are you in and what is your provider? Also, I’m wondering if this also happens with a different OS, like LineageOS or /e/.

UK. Using Plusnet Mobile which runs on the EE network. (but isn’t 100% the same as the EE network). I’m not sure when it started on the FP2, but I had so many recurring crashes, disconnections and problems on the FP2 that it was probably masked by them so could have been there the whole time.

I haven’t tried an alternative OS.