English

Help! :-( Tried Degoogling with e/os easy installer and now phone dead

Hi everyone,
I tried installing /e/os on my FP3+ that I purchased recently. I managed to follow all instructions with the Easy Installer. It detected the phone, downloaded files.

And then comes the step where rebooting it in fastboot mode is needed. I miss the 5 second opportunity to select the “menu” when rebooting and the phone reboots without that step. It basically rebooted with Google on it, whilst being connected still to easy installer on the pc.

Since Easy Installer said I could simply switch it off and reboot again (power and - Volume pressed) I did that. Unfortunately, I am unable to swicth the phone back on.

It seems completely gone.

Anybody any suggestions on what I could do? I am based in Italy.

Somehow think that Easy Installer should not be called that way if one can risk killing the phone? Or at least a big fat warning. Or am I missing something?

Thanks
Sim

It says in big, bold letters “Try the Easy Installer beta”. It’s beta software, not a finished product.
(But then again, which software ever is?)

If that is the case, the question is whether it is even really off.
Keeping the power button pressed for about 15 seconds should force a reboot.
If that doesn’t work you could remove the battery, wait a few seconds, and then put it back in and try again to start the phone.

Else … there are additional helpful sources you could consult according to the Easy Installer FAQ, last section “My question is not listed here” … Easy Installer - FAQ.

3 Likes

Thank you!! Let me try.
Yes you are right, it does say Beta and all that. Just one hopes it would not be killing the phone, but then again, maybe as you say it is still allive …

1 Like

Ok this is super embarassing (my only excuse am a non techie newbie) but as you suspected the phone was actuall alive. I held for 15 seconds… uhps!

I’ll be retrying the whole process again now. Pls cross fingers.

3 Likes

Agreed, that would be nice.
The good thing is that the Fairphones are not so easy to really kill.
Ok, the /e/ Easy Installer might perhaps not work for you with some bad luck (or missing drivers in Windows), but it doesn’t attempt to do things which could really kill the phone, so while it might look scary at first, most situations can be salvaged somehow, and we can try to help with that here.

2 Likes

Did it!!! So exciting! /e/ installed successfully :slight_smile: now I need to do the F Droid /Aurora thing to get the apps.

2 Likes

Only if you are not content with the /e/ Apps installer getting Apps via CleanApk.org, or if you want to use Aurora Store with your own Google account, or if you just don’t like the /e/ Apps installer (there’s always room for improvement).

Else the /e/ Apps installer includes F-Droid Apps and a selection of Play Store Apps already.

4 Likes

True, only just spotted that. Thanks for the additional background!
Didn’t expect this level of convience. It’s great.

2 Likes