Help for installing open os plzz

Hi there,

I have been trying to install Open OS on my FP2 since 2weeks. I don’t understand why it does not work. I have downloaded every program, manuel switcher, platform tools. In fact by the moment I connect my phone with USB cable, and double click on frlash for windows, a black screen appears and asks if I want to find a device: yes /no. and it stops there!!
I have made a screenshot that you will find attached to this email.
So have you ever heard of such a problem with you fp2?
Thanks for your kind help,

Presumably running Windows 20H2, have you checked Windows Update > Optional Updates as sounds as if “fastboot” not installed correctly? Although this thread appertains to OnePlus device it maybe of help to you:

 Hi Aspergerguy,

Thank you for your quick answer! No I have not checkedany windows updates…
Are you french? because we may speak in french?
Thank you bye


Okay, a bit of background for this topic.
I have been trying to help @Aliki install FPOOS on her FP2 with the manual switcher. We downloaded platform tools for Windows from SDK Platform Tools release notes  |  Android Developers, copied all needed files from the manual switcher folder into platform-tools, and then tried, to no avail. ADB works perfectly with USB debugging enabled, fastboot seems to work, as fastboot --version outputs the most recent fastboot version. Then when in fastboot mode, fastboot devices doesn’t output anything, and the manual switcher doesn’t work either. Disconnecting and reconnecting the cable doesn’t help (the cable works with adb so should also with fastboot). Rebooting neither.
We tried the procedure described in this post, as it seemed to me it had worked in similar cases:

Didn’t work. The “Android” driver is set as inactive, and I can’t find how to update it.

So I told @Aliki to try another computer, also under windows, to repeat all the procedures done up to now on the first one. Still didn’t work.

I’m at a loss to understand what fails. I don’t have a lot of experience with windows, so I may do something wrong without noticing.
Also, we can’t meet, which would be hundred times easier.

So feel free to give ideas!

1 Like

How about booting into recovery, installing the Fairphone Open OS OTA file via ADB sideload, then factory resetting?
I know it says the file is for upgrading from an earlier build there, but back in my Fairphone Open OS days (admittedly a long time ago) the OTA file could be used for complete installs nonetheless. Notice how it doesn’t need to know from which build you’re supposedly upgrading, so theoretically it has to have everything important in it.

I’m a huge fan of the official platform tools and meaningful current versions of everything, but if they don’t work, anything goes. There are still those complete install packages like Minimal ADB and Fastboot, which install everything including drivers. Worth a try, as well as simply older fastboot versions if you can get any.

1 Like

Would that work even with the AOSP recovery? I never used it…

Probably you contaminated me then :wink:

Will have a look, thanks!

  Hello there!

Excuse me for my super late answer :confused:
I was busy. Tonight I managed to install Open OS on my phone!!!
It was quite difficult to succeed with the fastboot etc. Eventually I used the app driverbooster on Download Driver Booster - the best free driver updater for Windows 10, 8, 7, Vista & XP. to help the flash for windows program… if it can help anyone…
So a big hug to everyone <3 Thank you all


Although it helped in your case, please never eher use something like DriverBooster on your Computer. It ain‘t realy able to determine the correct drivers. Getting the drivers from the computer or device manufacturer is always better, as you know, what you are installing.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.