Help! Can't use phone after latest update, can't install new OS manually because PC doesn't recognize phone

Thanks for your replies!
Yes, the phone can be switched to fastboot mode, the mode where I only see the Fairphone logo and the LED flashes blue, right?
There are not many steps I can follow. I can either end up in fastboot mode or in TWRP and whenever I reboot the system I end up there again.
I even inserted the SD card to my pc, copied the data for the last available update to it and tried to load one of the images in the folder, which may sound stupid, because I didn’t really know what I was doing, but I was desperate to try anything to render my phone usable again… I don’t have the faintest idea how I can proceed now…
Oh, latest news, now my phone seems to be stuck in fastboot mode. When I try to connenct it to my computer, I hear the windows jingle telling a device has been connected, but the phone doesn’t show up in Windosws Explorer. The device manager says, there is a “Kedacom USB device”, but I can’t interact with it.
Is there anything I can do now to proceed?

When I try to follow the steps described in the link (what I already tried yesterday) an I try to execute the flash-for-windows.bat, nothing happens.

I found and installed the "15 seconds ADB Installer v1.4.3, ADB, Fastboot and Drivers, but the installation didn’t
change anything.

Finding , I followed the steps to find out whether my android device would be detected there. Using the command “fastboot devices” the programme found the device “3a8fb644” . Does this help somehow? I feel like a blind person stumbling through an unknown room and try things not knowing if this might be helpful…

On my virtual odyssey trying to find anything that could turn this now unusable slab of plastic and metal into a usable phone again I tried to install Android Multitools to see if this could do anything for me. However, when I tried to extract the files the programme asked me for a password for this file although it was nowhere to be mentioned that I would need one.
I’m on the verge of giving up and asking my local compuer and smartphone specialist store to see if they can save my phone…

Founf out the password is simply “”. The programme works, but it also cannot help me to get out of fastboot mode.

Hey guys,

I have a friend in Freiburg who’s experiencing serious trouble after a failed update from 18.09.2 to 19.02.1… System gets stuck on first Fairphone logo, it goes to fastboot but does not get recognised in fastboot by several computers (which is why this tutorial fails:
We tried installing via TWRP (we’re running 3.1.1-0), but TWRP gives us the error message “Unable to find partition for path ‘/system’” and when we try installing anyway, we get “Zip signature verification failed” even though we deliberately disabled zip signature verification. In the “Wipe” menu, we performed a standard “Data, Cache and Dalvik” wipe, but this hasn’t helped. In “Advanced wipe”, we don’t see “System”, so we can’t perform a “clean wipe” either to just get it over with and reinstall the software.

Good thing is, we were able to save the data within TWRP by copying it to an external SD. But I have to admit that I’m done with my knowledge and have no idea how to get the phone working again without doing a complete wipe of the internal memory. I’m not sure that would actually help, as I fear that the “/system” partition mission indicates a larger underlying issue.

@urs_lesse or the others reading here, do you have any idea what the next steps could be?


As long as you cannot get the fastbooted FP2 recognized on any computer, I would only recommend to install Lineage via TWRP. You might want to update TWRP first though.

Which file exactly do you want to install this way?

You can’t install the manual installation file with TWRP, and OTA files for installing with TWRP are only provided for Fairphone Open OS since Android 7.

Worth a try when in TWRP …

A little more detail in between …

Else … fastboot mode on the phone and the fastboot command on a computer are the “last line of defence” when things go wrong, this has to work somehow … and usually it does.

Try the steps 1. and 2. here to get fastboot going … and report any errors with this …

1 Like


Thank you very much. I encountered the same problem after failed update.
This reanimated my phone. :slight_smile:
One strange thing was that TWRP complained on reboot that “there is no OS installed and
reboot will fail” (likewise). But after rebooting everything looks fine. :sunglasses:

Yes, it’s strange indeed.
Several users encountered this as a false alarm from TWRP already, at this point it is unclear why TWRP gets this wrong sometimes.

At least there’s no harm in rebooting anyway.

The problem I have is there’s no flashing blue light and my laptop doesn’t see the device?!! Help!!??!!

With older firmware there was no blue LED flashing in fastboot mode, so this could be normal depending on the OS version you’re coming from.

Whether your laptop “doesn’t see the device” depends on the definition of “see”.
When in fastboot mode, file explorers or sync programs will not be able to “see” the phone. The fastboot command on the laptop, however, should be able to “see” it.

Try the steps 1. and 2. here to get fastboot going … and report any errors with this …

The problem I seem to have is that when I try to enter the Bootloader or Fastboot mode, though I have the the opening screen ‘Fairphone’ display, there is no blue flashing notification light which appears to be a requirement of this mode. When I connect to my laptop there is an unusual tone - not the usual device connected tone and when I run the manual install, I repeatedly get the “WARNING: No Fairphone 2 found in fastboot mode”

You just keep Volume - pressed while starting or rebooting the phone … and the phone is in fastboot mode, as soon as the Fairphone logo appears.

When the phone is connected to your laptop and in fastboot mode …

  • Download the Android SDK Platform Tools
  • Extract the downloaded ZIP file to somewhere you can find it
  • Open a Windows command prompt (cmd) or a Linux/MacOS shell and change into the platform-tools directory, which got extracted from the archive
  • On the computer the fastboot devices command should now give a line with an ID and “fastboot” (in case of Linux perhaps as root or using sudo)

You lost me at… “Open a Windows command prompt (cmd)…”

If you happen to have #fairphoneangels in your vicinity, they could perhaps try to help you out in person.

Else … ok, using Windows then? We’re getting there :wink: .
So you downloaded the Android SDK Platform Tools and extracted the downloaded ZIP file to somewhere you can find it.
There’s a folder namend “platform-tools” there now.
While in Explorer, click on this platform-tools folder to display what’s in there.

Click into the location bar at the top of the Explorer window, enter “cmd” there (without the quotation marks) and hit Enter.
There’s a screenshot of this here in the " Using CMD command in File Explorer to open Command Prompt Window" section.

This should have opened a command prompt in the platform-tools folder now.

1 Like

Thanks for your help. I’m using a very old laptop running Vista and think that’s probably the cause of my struggle to make your instructions work!
I’m hoping to use a MacBook tomorrow and fingers crossed that will be successful.

Windows 7 not Vista! Still too old to manage it though?!

No, Win7 should still be fine (until April 2020).
In order to be able to help, we’d need to know exactly, what you did, which step failed and what the related error messages say.
Else it won’t be possoble to provide remote support.

If you are more familiar with MacOS it’s definitively worth trying with a MacBook. In case of issues please point out clearly which OS you are using to avoid confusion (on all sides).

1 Like

Tried to install update.
Phone entered Team Win Recovery.
Tried manual install following Fairphone support advice.
Repeatedly get “WARNING: No Fairphone 2 found in fastboot mode”.
Downloaded Android SDK Platform Tools following AnotherElk’s advice.
Not sure how to continue from here… Uncertain on instructions given…
More clear/basic direction for non tech person would be much appreciated!
No access to Mac at present, so sticking with Windows 7 if it should work.

So, no one has an idea to solve my original problem, the phone being stuck at the black screen with the Fairphone logo?
I think I’ll have to phone the support team tomorrow, I hope there is something that can be done to render my phone usable again…

Alright, alright, my Fairphone 2 is alive again! :star_struck::star_struck::star_struck:
I thought I had done everything I could and read every guide, but this seems to have been untrue…
🇬🇧 🇩🇪 ✏ Installing the Fairphone 2 from scratch in case of failure / Komplette Neuinstallation des Fairphone 2 im Fehlerfall and were very helpful.
Not before I installed TWRP Recovery manually via CMD on my phone could I proceed any further, but this did the trick. After the installation the phone rebooted normally and came to life again, wooo-hooo!
Thanks for every answer and hint from everybody! :kissing_heart:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.