Headset mic not working

So, if I understand you correctly, you can use the iPhone headset with the FP2?

Yep ! the mic should work without problems, but the buttons arn’t going to work ( its software and hardware dependent this cas)

Allow me to clarify: my headset is not made by apple, but it is fully compatible with apple products (mic + 3 buttons). In my FP2 I can only start/stop, no mic, no volume.

By the way: will my old headset work, which I used for the FP1?

As I use a headset with mic very often, I would be happy, if everybody who owns (and will soon have) a FP2 could list which heaset they use, and if it works. Also if it is an in-ear headset. I can’t use those, as I have tiny ears.

My impression is that you should avoir anything that is advertised as for recent iphones or ipads.
And there are some tiny silicon ear buds that could fit you.

Does anyone know what are the standards for adaptors? On FP2 particularly…
Can the staff provide a few details?


Here is a more detailed explanation for Fairphone 1. It appears that the headphones specs are somewhat similar, if I’m right.

Thanks Stephan. I hope I’ll find an adaptor…


this was the thread that finally made me register to the forum.

First of all, many, many thanks to Elispus for mentioning the standards. This question was bugging me for years. I am currently using a Galaxy Nexus until my FP2 arrives, and I had a headset not working and couldn’t find out why. Ok, I’m still found no specification for my phone and obviously no headset seller sees it necessary to give information about the used standard, which drives me nuts. But thats just my rant to this topic.

Why I answered is actually this very useful information; concerning your specific problem the following part is important:

Additionally, Apple has patents on their TRRS connection- in fact on the resistances (the actual ohm resistance in-line on the controls- not to get scientific or anything ) so that the headphones are designed to work only with Apple products. In other words- you could have a device with the same TRRS Pinout as apple products- but the headset wont work because the resistances (ohms) of the headphones send signals that your phone is not allowed to interpret into the correct actions (since apple patented these)

I hope this helps.

Wow, that’s kind of frustrating. Yesterday I tried my headset I used for many years on my iPhone4 and everything worked – except the mic. I can use the volume buttons and also the third button on the remote control for starting/stoping music and to skip to the next song worked (with Spotify at least). If anyone has a fully FP2 working headset with remote controlls and mic, which one is it? Or did you just get an adapter to get your old headset working?

There are headsets that say specifically for android. I have a headset intended for iphone, where the mic is working and out of 3 buttons it recognizes one (there is an app, I think its called jayz headset control, where u can check if the phone gets any imput from the buttons and then change what they should do). This is not optimal, so I guess one of the “android” headsets would be.

I tested a cheap PC headset with the FP2 and it worked, you can also use the microphone. Of course you need an adapter to connect the headset (two plugs) with the FP2 (one receptacle). You have no buttons which control the smartphone, but a microphone switch (on/off) and a volume control (with both no effect to the smartphone). And it does not really fit in a pocket.

For usage at home this headset would be a better alternative to an in-ear headset. I couldn’t decide yet which in-ear headset to take so I haven’t got one.

Hello again, thank you for your interest and contributions, however, this is getting more and more confusing to me…
As I reported earlier, I have a headphone set and an earphone set, both working as expected in apple devices (stereo sound, microphone, start/stop button, volume buttons) but have limited use in FP2 (stereo sound and start/stop button only).
FP2 specifications say that the jack standard is CTIA.
The manufacturer of my heaphones say that they are perfectly designed to be used with apple products AND that they are “CTIA 4-pole”. http://www.bowers-wilkins.com/Headphones/Headphones/Headphones/P5-Series-2.html
Wikipedia says that there are no standards for TRRS, but identifies two usages for audio, CTIA, including apple products and OMTP, that is essentially the same as CTIA but with mic and ground reversed. https://en.m.wikipedia.org/wiki/Phone_connector_(audio)
If that was the case, a simple adapter would do the trick http://www.ebay.com/itm/Genuine-Sony-EC250-CTIA-to-OMTP-Adapter-Converter-Headphones-Handsfree-Earphones-/261463302409?hash=item3ce06d6109:g:A4MAAOSwVFlT~eFK
I have not checked, so I cannot say it works…
An interesting contribution here also says that there is a resistance incompatibility, even if the jack is correctly adapted on the contactors side. It would mean that the adapter would be (almost?) useless… http://forums.androidcentral.com/samsung-galaxy-s3/189523-final-soultion-why-most-headsets-won-t-work.html
Btw, which Llama app do they refer to?
To summarize, the more I understand the more questions I have and my frustration was even increased when I found out who is behind CTIA http://www.ctia.org/about-us/current-members
Even if my impression is that apple is to be blamed for their proprietary design.
Any practical idea to use the B&W with FP2?

Thanks much Sonne

A lot of terms going on here and much confusion. I’ve got some standard Philips headphones which don’t state which kind of remote it has. The thing I notice is not being able to use the remote. It used to have start/stop and skip (double click) function and I was always told that’s industrie standard.
Anyone known with this?

This one.

The question is whether the mic works. If it does then the headset is probably CTIA (if it would be OMTP the mic wouldn’t work). If the mic works then your question is about the buttons on the remote - which judging by other posts on the forum can be tricky to get right. There are some apps that are occasionally recommended to map the buttons to a specific function - I can’t specifically recommend any (no experience) try searching around a little for recommendations (though I do note there appears to be a philips specific one that offers button customisation - but maybe only for 1 button models - and audio ‘enhancements’).

A post was merged into an existing topic: Headset buttons do not work

Hi everyone,

I have been following this thread for a while and now I’m going to post a conversation that I had with the support about this issue:

So… the one precise information is the hint not to use Apple-compatible headsets (even though some of you stated that this “CTIA” standard is used by Apple?).
If I get any update on this, I will let you all know!

1 Like

A post was merged into an existing topic: Location based profile apps not working on FP2